Amazon MP3 Albums

Hi, everyone! (Tach, zusammen!)

First, an unavoidable stream of praise for this astounding program. It is one of the rare tools where you think at some point: "Now I could use this special function", then poke around in the menues and discover that the special function is already there!

Absolutely amazing!

And now to something completely different: I am playing around with the source file and thought I could add support for MP3 albums. I tagged a row of albums this afternoon and discovered that one of them is not in "Music" but only in "MP3Download".

Changing "SearchIndex" to "MP3Downloads" is working O.K., the album is found; but there are no tracks given in the response for ItemLookup.
After digging in the Amazon WS API it turned out you have to query for the ASINs of the album first, and then get the track title by querying each track ASIN separately. I think I can assume this is not covered by the mp3tag script structure; if I get it right, only two calls to URLs are possible.

Then I thought I could just use the preview URL instead of the Webservice for the track title list. But when I changed [AlbumUrl] to "" and tried to run it with the data, I get a strange DNS error when selecting an entry in the search result window. Is it possible that there is additional data appended to the URL like access key, signature etc. in the background?

You would need that for the webservice obviously, but my AlbumUrl is plain http, right?

Here is the error message box:


Really no help regarding that AlbumURL problem?

Let me re-phrase:

"Amazon MP3Download" requires a different approach than "Amazon Music". Once you get the album information via webservice, you'd need an additional step to see the track details. A third URL call is not possible in source scripts, if I understand correctly.

So I tried to use the preview URL to get the HTML album page instead of using the webservice, because the track list would come with it and I could use the second URL call to get the track details.

Unfortunately, the program seems to do things to the preview URL that are most likely targeted at the webservice access - which I don't want to use. I suspect these alterations cause the strange error message that I get:

These are my URL entries:


And later at the top of ParserScriptIndex:

regexpreplace "<Binding>[^<]+</Binding>" ""
    findinline "<Item>"
#    say "="
    findinline "<ASIN>"
    sayuntil "</ASIN>"
#    say "&ItemPage=1&ResponseGroup=ItemAttributes,Small,Tracks,Images"
    say "/mp3tag-21"
    say "|"
    say ""
    movechar -10
    sayuntil "</ASIN>"
    say "|"