Another Discogs problem


#1

I see a number of other complaints about problems retrieving info and cover art from Discogs, but none of them match my symptoms. I get the following error message:

"Failed to authenticate using OAuth (1) >> -2146893018: 2148074278: The message received was unexpected or badly formatted."

This has been going on for at least a week. I get the same error message no matter what track or album I submit, and no matter whether or not I'm logged into Discogs with my web browser.

Seems to me that it may have worked once only, just after I registered at Discogs a few weeks ago, but I'm not certain about that.

This is using Mp3tag 2.84a on Windows XP SP3.

Any suggestions?

P.S. - I really miss the Amazon integration. Not only was it pretty seamless, but the artwork was almost always of good quality, and the size was just right for me (500 or 600 pixels square). Discogs seem to be of lower quality in general, and the image size varies a lot.


[X] Failed to authenticate using OAuth unter Windows XP
Tag sources cover-art problem
Discogs
#2

see this google search on the topic of OAUTH errors:
https://www.google.de/search?q=oauth+discog...kNqKT8QfVx4uwAQ

Then it would be nice to hear what you have tried already and what has led to success (or failed with no improvement).

If the problem only recently arose: what about your system time? Is it accurate?


#3

Nothing I find at that search link describes my problem precisely. Also, there are few suggestions. Some lucky people mention that things magically started working later, but this has been going on for quite a while for me and nothing changes. I did try one suggestion, which was to revoke Mp3tag on Discogs as an authorized application. No change, I get the same error message.

System time is synchronized once a day with an internet ntp server.

Do you know what that error number means? "-2146893018: 2148074278"


#4

see e.g. here: https://support.microsoft.com/en-us/help/98...erver-that-requ

apparently, your client does not answer with the expected certificate.
No, I do not know where to get it. Perhaps you are missing an update.


#5

I'm getting the exact same error and it's been happening for over a week now. Usually problems like this only last a day or two on discogs and then go away on their own but not this time.

  1. Tried uninstalling mp3tag and then reinstalling the latest version (v2.84a). That did not help.

  2. Renamed the mp3tag config file and let it rebuild a new one. That did not help.

  3. Revoked mp3tag privilege on the discogs website but this is of no help with this problem as the error never allows the registration process to take place when you run mp3tag and try tagging a file.

  4. I'm not running a firewall and have not changed any settings on router or computer.

  5. My system time is updated everyday through a government website and I also tried updating it manually. No help.

  6. Both freedb and MusicBrainz work just fine.

It would seem the error message is indicating that the reply message being received from discogs by mp3tag is incorrect or corrupted (it states 'badly formatted'). The question is - Is this a problem with discogs or mp3tag?

Any help would be most appreciated. I prefer using discogs but the nearly monthly connection issues are getting old. At least in the past those went away after a day or two though.


#6

exactly the same error message here, running XP SP3. even installing version 2.84b did not help. freedb and musicbrainz are ok.

pleeeeaaaase help. thank you.

B. Müller


#7

I have a general question/statement on this subject have any one tried the DISCOGS PONE from the Web Sources Scripts (/t/9226/1 the odd one does not work such as API-Artist but the majority of them work just fine....and there are some interesting alternate Discogs search options available there...


#8

none of the discogs pone search options is working (error message: "-2146893018: 2148074278"), same error message for discogs release id.

quite sure the reason for these messages comes the discogs side.

B. Müller


#9

Weird, mine all work save for 1 or 2 of them...(just double checked and yes they work)...


#10

I've further investigated this issue and it seems that all users who are receiving the error message

are using Windows XP SP3 or Windows Vista.

The CDN used by Discogs recently moved to dropping support for TLS 1.0 and TLS 1.1 so that Discogs itself also moved on to the more recent and more secure TLS 1.2 standard for HTTPS connections.

Unfortunately, TLS 1.2 is not supported by Windows XP SP3 and Windows Vista, so that connections to Discogs won't work there.

Kind regards
– Florian


#11

Thanks for the reply Florian. :slight_smile:

My son had helped me do some investigation on this and we came up with the same result. I was going to post what we found but won't need to now.

It's a shame there's no fix but XP is getting long in the tooth. I can still get cover art through my account on the Discogs website so it's not the end of the world.

Thanks again for looking into this.

-Mike


#12

Guess that I am an anomaly than the Standard Discogs search works fine as does the majority of the Pone / Joker Updated scripts?..weird but will take it mind you from what I read above it is older operating systems that are having the issues and not Windows 10.


#13

I suspected it was something like that. I had planned to test it with another XP installation but hadn't found time to do it yet. I guess I don't need to now. I have several other reasons to finally move from XP to Windows7 - this is just another one. I'll make the transition sometime this fall.

Thanks for looking into this, Florian.


#14

Please ignore this duplicate post. not sure what happened. sorry


#15

Folks I just now tried to sign up with Discogs and never received the Confirmation code. It's not a spam issue; so it appears to me the site is experiencing major problems. Hopefully they are aware and will get things back to normal this WE, otherwise we'll have to wait until Monday? I'm new to Mp3Tag & Discogs. I wish I discovered you earlier!
Hope this helps.


#16

Do you get any error messages?
Can MP3tag access the internet? Or is it blocked in your firewall?
Check the Mp3tag internet access with Help>Check for new version.


#17

No, I cannot use Discog until I get and use the authorization email & link that never gets sent. It is NOT an issue of it getting lost in spam and I won't bother trying with another email as judging from the messages that it's not working for anyone, it's clear Discog server isn't working properly. Or is it working for you ohrenkino??


#18

FYI
I just received and used the authorization email and Discogs seems to be working for me.


#19

Hi guys,
Since yesterday Discogs Pone isn't working at all for me.
Is anyone else experiencing any problems?

When I click on the album in the Discogs list, mp3tag loads up the Discogs info but there isn't actually info in there, it's blank [see screenshot].

When I click on OK it just says 'saved tag in 0 of 0 files'.

Is this an issue with Discogs site? Anyone any ideas?
Many thanks in advance.



#20

Are you still having a problem with this? I just tried it and it's working as expected for me (using Windows 10, of course - XP still doesn't work.)