Another Win10 issue with track number

In Windows 10 explorer the '#' column displays a number, which I appears to be an assigned track number, see attachment 1. This occurs many times throughout my music collection, but not on all files.
The file has extended tags and only those tags displayed, see attachment 2.
I have noticed that if I convert the file, the displayed tag disappears, but MP3 to MP3 is not recommended.
How do I remove the tags that Windows is applying to the files which have no track number assigned?
I use track numbers for album tracks and not singles.


2

I see that you have APE tags in the file - so it may be that the WE reads the data from there esp. as you do not have a field TRACK in the ID3 data.
So check the settings in Tools>Options>Tags>Mpeg and what happens if you read APE tags - does the mysterious data appear in MP3tag?

Unless you desperately need APE tags, get rid of them.

The APE tag is already configured to remove.
I assume this means that for a MP3 non APE file there will be no associated tags left over.
If this is already checked to do so then how do I remove them?
Also, as I only have those tags shown above which are all added by me, then why would other tags be present?
3

You chose the wrong options. Check those under "Mpeg" (one up).
You would have to delete or cut the tag.
To remove only the APE tags, I would set all other tag versions to OFF and APE write also OFF.
Then load the files,
select all files
Use the file list context menu and "Remove Tag".
Reset Tools>Options>Tags>Mpeg to read, and write ID3V2 tags and see if you got all the data back.
And then check the explorer what that shows.

This did nothing for me except to lose all the original tags!
After some experimentation I found that I needed to uncheck 'Tags | Mpeg | Remove ID3v1 & ID3v2' and check 'Tags | Mpeg | Remove APE'.
Select the file(s) then CTRL+X then CTRL+V.
Sorted!
Thanks for you help.

Well, in the end you succeeded - yet I wonder what you understood when I wrote