Antivirus [Avast] problem when sending files to Mp3ag [with Mp3tag Total Commander Button]

I have been using the Mp3tagTCButton created by user @dano for quite some time now

Unfortunately something like a month ago an update of my free version of Avast antivirus software made it less usable. And that is because if I use it to send file or files to Mp3tag from FreeCommander I will get to see them in Mp3tag. But also after something like 1.5 seconds I will get a popup window from Avast informing me of a threat IDP.HELU.Autolt9 being blocked which is coming from the process of C:\MY FOLDER WITH Mp3tag - Total Commander Button\Mp3tagTCButton.exe; under the name of something like D0A3.tmp or 3BFC.tmp. I can add it to the exception list but this will have to be repeated for the very same file the next time I will load it to Mp3tag with the Button- which is logical, as it is being handled as temporary thing

But here is the funny thing about it: I can send in the exact same way the very same file to my audio editor [Sony Sound Forge 7.0] and it will not get such prompt from Avast

And here is the not funny thing about it: despite manually adding to exception list in Avast paths C:\MY FOLDER WITH Mp3tag - Total Commander Button\Mp3tagTCButton.exe and C:\MY FOLDER WITH Mp3tag - Total Commander Button\* I still get this pup up windows from Avast

So as you can see, if it was not for the audio editor working A-OK I would not have posted this not on Mp3tag ere but on the Avast forum. But how can it be that Mp3tag is affected by this while other software is not?


But it seems that I also have [just a minute go] already found a solution to the problem:
after adding the path in form of "C:\MY FOLDER WITH Mp3tag - Total Commander Button\Mp3tagTCButton.exe" instead of just C:\MY FOLDER WITH Mp3tag - Total Commander Button\Mp3tagTCButton.exe [i.e. with quote marks instead of without them] the problem went away. Which is illogical, because paths for those temporal exception were created / listed by Avast without the " signs [and that was why I did not try them out in the first place]. And what is more mind bothering: after removing all of the exceptions from Avast [i.e. also the one for the Button] the problem also seems to be no more

But how is that possible at all?

I know: it seems like a problem of the antivirus software- but then again there was this duality with audio editor


I am using Mp3tag 3.04b with FreeCommander XE 2020 Build 810a 32-bit public on Windows 10 x64

Sorry, to me it looks like the antivirus program reports a false positive.
It worked before, now it does not, the button program is still the same, only the antivirus program changed ... ask them.

3 Likes

Also note that Windows in general has issues with spaces in command/path strings. The quotes address that.

Not sure what stumbled in your sequence of programs, but perhaps the anti-virus (after an update?) was uncomfortable and flagged the threat out of an "abundance of caution".

1 Like

I uninstalled Avast and installed [off-line] AVG AntiVirus - which happened to be a clone of Avast, so it had the same issue

I installed then [off-line] COMODO - the seems to be absent


Why is it that every couple of years I have to change the antivirus software because it goes bonkers in some way? I cannot even remember which antivirus software for me this is

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.