Attempting to install


#1

Hi all,

Have downloaded and attempted to install version 2.49 (as well as a couple of older versions... same issue) and get an error at the final stage of installation, telling me the file can't be created, and I should close all other running instances of MP3 tag...

Now, I don't have any, never have had, and there's nothing I can seem to find in the Windows environment to let me find and kill any "other" versions or instances of the program.

Windows 7, 64 bit, home premium, fully patched.

Any ideas?


#2

Are you installing over a previous version of Mp3tag?

I've been running into this more and more often with recent versions. Sometimes when I quite Mp3tag there remains an Mp3tag task running that isn't visible. You either need to open the Windows Task Manager (Ctrl-Alt-Delete) and find the old Mp3tag process that's running and kill it, or else you can reboot the system, then try installing again.


#3

HI JJ,

I've never had ANY version of MP3 tag on this machine, so there's no way possible for there to be any old stuff hanging around, but I had already looked in task manager, nothing showed in processes or applications... Hence the question about what to do when a completely fresh install fails as well as attempting with older versions.

Reboot no use either... situation remains the same.


#4

The only thing I can think of is that the error message from the installer may be wrong or misleading. The installer may not have been able to install a file due to some other circumstances. My guess would be a Windows permission issue or possibly an anti-virus or firewall problem.

Make sure you're installing the program using an administrator's account.

On my system (Windows XP, so it may be in a different location on Win7) there is a log file located at

C:\Documents and Settings\Jim\Application Data\Mp3tag\Mp3tagError.log

If you have one, maybe it will contain information that is helpful. Mine only lists the application, data and temp folder paths, so I'm guessing it was created by the installer.


#5

Did you try Right Click and Run As Administrator on the Setup ??


#6

JJ, this Mp3tagError.log (you mention) is (re)created every time Mp3tag starts.


#7

Ah, I didn't notice the file date. You're right.


#8

But you made a good point, does anyone know if the installer creates a log file ? Or are there switches for the installer to create a detailed log file ?


#9

I did... Issue now solved.

Thank you huge amounts. Thought I fail to understand why running as an admin will get around an error (incorrect) that there is earlier data from the program...

But what the hell, it worked.

Thanks for the tip.


#10

Good for you, but no surprise, because Win7 is more picky about rights and is not as Forgiving as for example XP, but glad to hear that you solved your problem !

Here is some reading for you: User Account Control

Ps: 13:28
But I don't wanna take credit, in post #4 JJ already suggested "Installing the program using an administrator's account"


#11

I think it's just that the installer gives an incorrect error message. At one time, when the installer was unable to write the program file, it may always have been because the program was already running (smarter installers might send a signal to the program and it would close itself, but...). With Windows 7, there are new possibilities, such as permission problems, that give a similar situation and the installer only thinks it's because the program might still be running.

I would suggest that it's time for some new logic in the installer to deal with theses new scenarios.