Batch Removing Part Of The Comment Tag & Adding It To The Album Tag

Is there a way for me to batch remove a portion of the comment tag and add it to the Album tag? I have a separator (space,hyphen,space) separating the portion to remove...which would be after my separator.

Take the following steps:

Use an action of the type "Guess value"
Source: %comment%
Format String: %comment% - %part_comment%

Now use an action of the type "Format value" for ALBUM
Format String: %album% %part_comment%

Finally delete the user-defined field PART_COMMENT

You can do all this in an action group

Thank you for this info. I selected Actions from the Actions pull-down menu but I don't see Guess Value as a choice. I only have Case Conversion, CD-R, "something I don't understand", and Standard. How do I get Guess Value and put all this into a group?

You would have to create a new group with new actions in it.
See the FAqs:

Thanks for that info. I got it working but two things...

  1. The album tag created has a space in front
  2. I'm not sure the user-defined field is being deleted. Is there a way I can tell? I didn't see a delete action so I used remove. Attached is a snapshot of the group action. Does it look correct?

snip

Of what in front, of the album?
This can only be if the album-tag already has a space in front or if you put a space in the format-value-action in front of %album%.

Or do you mean in front of the added part of the comment?

Have a look at all tag-fields with the extended tag-view. (Press ALT-t)

This will happen if you do not have an existing album field.
So what is "created" when the original task was to "add" something?
If you want to move parts of the field COMMENT to ALBUM then you can do that in one go (provided, there is no ALBUM field):

Action of the type "Guess value"
Source: %comment%
Format string: %comment% - %album%
(or something similar. Hard to say what the pattern should look like as you do not show us the original data).

Yes, I don't have any existing ALBUM tags. That's why the space was added. I have this working now in one go. Thanks a lot ohrenkino and poster for your help!