Blinking mouse cursor when using Actions

Hia peepz :slight_smile:

I've restored my actions from a back-up and now when I click on the actions-button or menu (both have the same issue) my mouse cursor blinks reaaaally fast for a couple of seconds before opening up the menu.
I tried to back them up again and restore them, but the problem still exists.

Maybe I made the initial backup the wrong way, but there are too many actions and groups to do them over.

Is there a way to fix this?

I love this program and use it a lot, but this issue is making me use my actions a lot less :wink:

Thanks :smiley:

And to the creators of MP3Tag: Well Done! :smiley: Awesome piece of software :wink:

Greenz
Bran

That's a Windows 'issue' not an MP3tag one and is the amount of items in the list object you are trying to display causing the menu to 'blur' and 'focus'.

Move the mouse cursor off the menu header and the 'flashing' will stop.

I am inclined to believe that but the rest does not really help: moving the mouse off the menu title will close the menu. So I do not really win.

Actually, I see this behaviour as well on one of my PCs that accesses the same portable installation as does another PC that does not show it.
The behaviour first occurred in January after the Windows update.

It may be that the virus checker interferes or that the access permissions make it more difficult.
Or it could have to do something with the graphics driver: the other PC has AMD graphics, the working one Intel. I like this last idea best as the flashing machine uses W8 as well as W7 and both OS show the flashing mouse cursor which toggles between the normal and the half-busy cursor.

I am still investigating.

My main pc has AMD graphics :wink: But it wasn't an issue a couple of months ago.

I thought I backed up/restored wrong. But apparently I didnt? :wink:

Hope to hear back from you guys soon then :slight_smile:

Yes, the first reports date back to November 2013 (German forum)... If you could check if the owner of the mta files is the same that opens Mp3tag? Then I wouldn't have to do it.
Because if you say that your restored the settings ... it could be that the files still show the old user-id.

All the files show the same owner and location :wink:
I didn't have this issuem until I set them back. After I did that, I can't seem to get rid of it at all.

I've even removed ALL actions from the folder and still it goes 'hyper-hyper'

Hope there's a fix to be found, because I use this program daily and this 3/4 second wait before I can open up my Actions is becoming really annoying.
If I want to be able to properly re-tag all my mp3's, it takes me at least 3 passes before I'm done (per selection) and this way it's becoming quicker to do it by hand lol

Move the cursor off the menu header not off the menu entirely, it will stay open and the mouse cursor should be off the object that is in a blur -> focus area.

No, I can move the cursor around the whole application without it getting out of that flashing mode until finally the menu opens.
The blur comes from a very fast toggle between the "busy" and the "normal" cursor.
So apparently you do not have that problem. Be glad.
In the German forum there are at least 3 other posters who have that same problem.

Same here. It's quite the annoying issue. It stays when I take the cursor off the menu-bar.

Honestly: It's making me hold off retagging MP3's until I can fix it.
The wait gets annoying and when I have to retag my dj-files or mixes, I háve to make several passes (filter brackets, artist names and features and so on).
So having to wait a good 5/10 seconds before the cursor is out of that hyper-blinking-mode gets really bothering.

So I hope they can find a proper fix for it, because simply "Move it away from" is not really fixing it :wink:
And I've never really had this issue, until I started using a backed up version of my actions.

Peepz: PLEASE help with this and not the kinda advice, that I could've thought of. I know that when my cursor is being a pain, I might wanna try a different area on my screen.
And when backing up, to try a different version of MP3tag (didn't work). Or removing the backed up files from this install.
I even uninstalled, run CCLeaner, fresh install (no issue) and moved in my own actions, to find the issue rise up again.

Frankly: The main reason I use MP3tAG is because of the actions and the rename function.
Now that the actions are acting up winkwink*, I'm less inclined to create really extensive actions.

So I hope you guys can post a PROPER fix for this. :wink:
Thanks :smiley:

p.s. The ownership of the MTA files is correct :wink:
And at first I thought it might be because I accidently copied the files to 2 locations, where Win or MP3tag could be looking. Nopes. It's only in that %user%/bladibla folder :wink:

What OS is this happening on and are your display drivers up to date?

Sorry for the late reply.

My display drivers are all up to date :wink:
But I don't understand why this only happens with MP3tag?
If it's got something to do with mouse-focus, than why just with MP3tag.

I seriously doubt it's just the video-drivers or something.

Could it be that the array for the Actions is not being properly loaded?

I hope the guys from MP3tag manage to fix this :wink:

@Bran Dragon

I started a thread about this problem in October last year in the german part of the forum.
The problem began after I updated from Windows 8 to Windows 8.1

I don't know wether it is of any help to you, it's not really for me:
If I start Windows in safe mode the problem is gone.

:wink: My german isn't all that good LOL :wink:
So I doubt it'll help, reading through it.
I don't thing, having too boot into safe mode to have my actions respond normally is a proper fix too it.
Like I said, I'm hoping that there is a fix for it so I can regulary use MP3tag again.
You're solution would mean that I'd have to rebot every time I'd have to retag.

And I forgot to answer @Christ Hirst 's question, I'm using win7 :wink:

I suppose the real solution is to find what is causing the delay in loading the actions list rather than hoping someone will fix a problem they probably don't have and cannot recreate.

I hope they do find a way to recreate it. Apparently it's not a very uncommon issue, so recreating the circumstances should be doable :wink:
Hopefully the MP3Tag-team picks this up.
There isn't a program to retag that's thís good and I well and truly miss it...

I just had some success:
Close MP3tag.
Search your "program files\mp3tag" folder for the file

mp3tag.cfg

Rename it to something like

_mp3tag.cfg

Start MP3tag and open the Actions menu - it should open just as quick as the others.

:smiley: :smiley: :smiley: :smiley:
Thanks a million! Works like a charm! :slight_smile:

Solved ^_^

A little update:
The issue does seem to be solved when I remove or rename the config file.
But when I change an action or something, it gets put back :wink: Kinda obvious, it being a config file and all lol
I don't mind removing it every time I add a new action, but I do mind that the tag - filename syntax gets removed as well and for some reason I can't copy past my syntax back.

Is there a chance this gets fixed in a future update of MP3tag?
Apparently the blinking cursor is triggered by something in that config file. And if it would just be "remove that file" and do it again when you add or change ur actions, it'd be fine :wink:
Especially when the other options are still saved ^_^

I'm not a coder or anything lol so not that knowledgable on this kinda stuff :stuck_out_tongue:
But do hope this helps the MP3tag community in some way :wink:

Same problem here. I renamed the cfg file and it works, i haven't changed an action in the meantime, but I noticed that a new cfg file was created when i started mp3tag (obviously). So, as I see it, the creator of mp3tag could easily add a function to delete this cfg file when you close mp3tag.

Well, with a deletion of your mp3tag.cfg you partly lose your settings in mp3tag.
That#s not a solution for the problem.