Can not tag from sources anymore

Hi,

I've always tagged my music by going to Tag Sources--->Amazon.com. As of a couple of weeks ago, this does not seem to working anymore, using any of the sources listed (except freedb, which is crap andhas no covers). I have reinstalled mp3tag and have the latest version.

Any ideas?

Have you checked your firewall/router settings? Some routers have a content-filtering module that blocked web sources for some users.

I only use WinXP firewall. I turned Windows firewall off and tried it but same problem.

Unfortunately the router/modem we have is from the telco and they don't give you the password once it's set up - lame. But this problem only just started and nothing has changed. Is there any other test I can do see if I have access to those sources?

Maybe I should completely remove mp3tag from my system and do a fresh install (I just reinstalled before).

Still no luck. A clean install didn't help.
Am I the only one having this problem? :frowning:

I have had this message infrequently. It seemed to me to be when the string that was sent to the external source would not return any results.