Cannot access URL via secure bookmark

Hi there,

I am having trouble changing any Tag using mp3Tag for mac in a specific folder on my NAS-drive - while using another folder on the same NAS drive I don't have any problem at all.
One difference ist that the one i cannot tag is used by "BluOS" so that the mac might think it is "mounted".

To be clear - I can read every file using the mac. But I can't save any changes.

Using mp3 Tag for windows has no trouble at all.

Has anyone an idea how to get rid of the "Cannot access URL via secure bookmark" error using the mac - which forces me to still use my old windows-Notebook?

Thanks in advance.

Hi and welcome!

I've moved your topic here to #mac which currently has not distinction between bug reports and other topics.

I still need some more information on the issue that you're experiencing:

  1. Which version of Mp3tag for Mac are you using on which version of macOS?
  2. How do you load the files that produce the error (e.g, by drag and drop or via File > Open...)
  3. Are you loading individual files or are you loading folders?
  4. Is Mp3tag asking you to allow access to the files in question when you're attempting to save? If so, are you allowing access or are you dismissing the dialog via Cancel?

It's difficult to pin down this issue, that's why I'm asking for all the details.

Hi Florian,

#mac sounds good to me - as it is still e beta :slight_smile:

to your questions:
1. Mp3tag for Mac --> Version 1.0.0-beta.4 (26)
MacOS Version 11.1
2. using the folder button - so I guess it is File>Open...
3. I am loading folders. But I just checked loading just one file. Still same error
4. nothing is asked. When saving the error ocurrs directly

Hope that helps a bit to pin it down...?

Thanks for the answers! It doesn't reveal anything special, except that it doesn't ask for file access.

More questions :sweat_smile:

  1. Are you running Mp3tag from the /Applications folder or is it located elsewhere?
  2. When you run defaults read app.mp3tag.Mp3tag SecurityScopedBookmarks from Terminal.app, is the folder or a parent folder on your NAS drive listed?
  3. Have you opened a lot of individual files (>3000, not folders) before the error occurred?

Well - lets see if we can get closer to it. Somehow I think your second point might be the issue. Though I don't know how to solve it...

1. I am running it from the standard folder. Thus applications
2. most folders listet are on the NAS drive. one folder is also included to where "BluOS" has also acces to. and in this specific single folder I can make changes.

Example:
"/Volumes/Share/02_Flo/08_Musik_zuSortieren/GreenDay" = { }; --> everything is fine
"/Volumes/Share/08_Musik/Emil Bulls" = { }; --> everything is fine
"/Volumes/Share/08_Musik/[everything BUT Emil Bulls]" = { }; --> error

3. not that I would know. For sure not since the last system restart

So I guess i might have to include the whole folder
"/Volumes/Share/08_Musik" to the SecurityScopedBookmarks
But how ?

Thanks for the feedback!

Usually, it's enough to open the folder via the open panel to give Mp3tag access to it. It then creates the secure bookmark in the background and stores it, so that you're not asked for permission at a later point in time (e.g., when renaming a file to that folder).

So, if I understand you correctly, if you're trying to open one of the folders under /Volumes/Share/08_Musik/ which are not listed, Mp3tag doesn't create a new entry for it.

Does it create an entry if you open the /Volumes/Share/08_Musik/ folder?

To check if the entries are created, I suggest closing the app and check as outlined above.

So, if I understand you correctly, if you're trying to open one of the folders under /Volumes/Share/08_Musik/ which are not listed, Mp3tag doesn't create a new entry for it.

That is right. no new entry for the folder is written then.

Does it create an entry if you open the /Volumes/Share/08_Musik/ folder?

That will take some time (hours - I guess?) - as in that folder are a couple 1000 flac files. Is there any way to manually ad a folder to the SecurityScopedBookmarks list?
Anyhow - will let you know as soon as I do have the result vom Mp3tag

You can also start reading the huge folder and cancel the operation after some files are read. It should still create the secure bookmark.

just canceld it - after about 1000 readings...
closed Mp3tag
checked again using the terminal command above, but the folder * /Volumes/Share/08_Musik* is not in the list

That's very strange. Thanks for trying!

Are other settings preserved, e.g., if you're adding a new column to the file list via "Preferences > File List"?

And are local folders added to SecurityScopedBookmarks, e.g., if you open a new folder from a location that is not already listed?

What exactly do you meen by this? What I am supposed to try...? Sorry...

Are other settings preserved, e.g., if you're adding a new column to the file list via "Preferences > File List"?

When opening another folder - nothing is added to the list - but still everything is working fine.
For example:
/Volumes/Share/02_Flo/08_Musik_zuSortieren/McKenzie wasn't added - but I was able to do changes in the tags

Well I just found the main-directory in the list though

/Volumes/Share

but still - I can't do any changes here

/Volumes/Share/08_Musik

I was asking if you can perform any of the other changes that involves updating the user preferences and see, if the changes are written to the user preferences at all.

An example would be to go to "Preferences > File List" and add a new column or change the name of an existing column. Then restart the app and see if the change is still here. It would then show if the problem is related only to the secure bookmarks or an inability of the app to update its preferences on your system.

An additional idea is to check Console.app for details on those errors (and potential others). You can use it and filter for the "Mp3tag" process.

ahh - ok. Now I got it.
I changed "path" to "paths". That does work. Also restarting the app afterwards it still remains. But the writing problem of that folder as well

Concerning "console.app". It shows the following error
Error resolving secure bookmark: Error Domain=NSPOSIXErrorDomain Code=17 "File exists"

Thank you! Still cannot make any sense of it — are you just changing metdata and try to write the file? What file types are those?

To try something else you can just backup the settings (in case we need to revisit them) and delete the bookmarks. Just to make sure that not some old data is preventing everything from working as it should be:

defaults export app.mp3tag.Mp3tag ~/Desktop/Mp3tag.plist
defaults delete app.mp3tag.Mp3tag SecurityScopedBookmarks
1 Like

Just the meta data. Changing the genre and unifying the ulbum name is all I am trying to do.

The files are mp3 and/or flac

Just deleted the SecurityScopedBookmarks list and - yeah :smiley: that was the solution. everything is working again.
Thanks a lot :smiley:

And sorry for beeing just a bigginer mac user - not too much into the innerts jet :wink:

1 Like

Happy it's working now. Just to make sure: is it adding the bookmarks as expected now?

And for my taste, this was already pretty advanced stuff — Terminal.app, Console.app, using defaults :sweat_smile: ... thanks for the time you've put into this.

it is. the two foldery I have taged have been added to the bookmarks as expected.
Thanks again :slight_smile:

and well - then thanks for helping to understand my mac better :smiley:

1 Like

Having the same (Cannot access URL via secure bookmark) problem. I gave mp3tag, "Full Disk Access" and ok! But then happened again and deleting SecurityScopedBookmars solved my problem ! Running 10.15.7 and all the mp3's located in my main internal ssd. I tried to batch edit multiple files (about 5000) from "smart folder" which means individual files...