Cannot Change Tags

I was able last night to change tags of mp3 playlist, but today when i tried to change tags.

A pop up comes up with "name.mp3 Cannot be opened for writing" .. What can i do to fix this>?

I have the same problem.When I had Window XP this software was working with absolutiliy no problem but since I have got a new PC with visa home premium 32bit and it gives me the error.

I get the same Cannot be opened for writing error. Vista Home Premium. Has anyone found a solution? This is the case for the USB-connected external HD. Tagging works fine on file on the internal HD.

I just tested with some files inside my user directory and everything worked fine. However, if the files are in a system folder or any other folder that requires admin rights for writing, the error occurs. I first noticed this in WinRAR as I tried to unpack some files to C:\Windows\Media and got a similar error.

Florian, if you want to reproduce, simply put a file in C:\Windows and try to edit its tags - it won't work. The WinRAR support told me that this cannot be avoided. The only work-around is to disable UAC entirely.

Edit: Maybe it helps if you (Florian) modify the manifest and make Mp3tag ask for admin rights, but then I guess Mp3tag will not work when launched by a normal user who does not have admin rights.

I had the same poroblem.

The files were on my Desktop and I moved them to my user folder:


Now I am able to save them.

I have Vista and for some reason I cannot move some folders from the desktop to the user folder. It asks for Admin Permission and even when I allow it won't move the folder but it will let me copy them. Then it starts working. I don't really know why I just do it and move along.

Anyways I copied them to my user folder and now it works.

Having the same issue with Vista Ultimate. Have all of my music on an external USB drive. Don't really feel like moving everything around just to re-tag... Any new solutions?

I found that running mp3tag as administrator under vista solved this problem for me.

I'm facing the same problem.
Files are in local hard drive in C:\Documents and Settings\Sudeep\My Documents\My Music
I'm the administrator myself and there are no other users.I'm running Windows XP SP3.
Please please help.
Thanks in advance :slight_smile:

Pleae help :frowning:

A try:
Download Sysinternals Process Explorer, start it, go to the pulldownmenu "Find" -> "Find Handle or DLL" and type in the name of a blocked mp3.
If the mp3 is blocked by any application, process explorer will show it.

"name.mp3 Cannot be opened for writing"
Is this your problem?
Can you elaborate what you did before the problem has been coming up?


Nothing actually.These are mp3s I had on my PC.So in a folder there are like 53 mp3 files,but when I try to tag them by selecting all of them in mp3tag and doing a right click and selecting Convert -> Filename-tag,it is tagging few files and for the rest its giving error "<file_name>.mp3 cannot be opened for writing".
I also tried tagging the failed file only,but getting the same error.
Running Winows XP SP3 with mp3tag ver:2.43
Please help.

Hmm, confusing situation ... one thing came in mind ... this error message is usually shown when files are empty (0 Byte) or destroyed, maybe improper filenamed or filetyped.


The files are not 0 bytes and they are playing fine.Also they are all named as -.mp3.
Please help me out :frowning:

I am having the same problem with Windows 7 with version 2.47b. What causes the error is opening the song in WMP 12. I could not open the song then try to edit it, but some of the songs I am messing with I am not sure if they are even titled correctly. Has any one found a solution that applies to this situation?

I am not quite sure, but: in Windows Vista the slideshow sidebar application was fed by wmp. If you edit in a folder that wmp watches then it could be that it tries to open (or even opens) the file you are currently editing.
To me it looks as though any editing program has to be really fast to grab a file before wmp does it.
I had trouble to move folders with folder.jpg in it as wmp (or the explorer) insisted to keep the thumbs.db file.
So, the combination of Windows 7 plus a NAS apparently slows down the file access that mp3tag and the rest of Windows get into conflict.
A remedy might be to dedicate a local path to editing and then moving the files to the external data storages...
But this is only a wild guess.

well this problem seems to still be around :frowning: I am editing a large number of files (using MP3 Tag 2.62 and Windows 7 Ultimate) - and many of them say file cannot be opened for writing

all the songs are on an internal hard drive - and the ones I;ve tested play just fine in iTunes

what's the latest on this problem?

I've been using MP3TAG for years under XP Pro on an external firewire-connected hard drive, and under Win 7 32 bit on that same machine, with no problems.

Migrated to a new 64 bit Win 7 machine, with the same drive connected by USB 3.0, and MP3TAG no longer modifies tags.

No error message, but when I edit a tag - any tag - move to a different song and then back to the one I modified, it is the way it was before I modified it.

I just tried the trick of setting MP3TAG to run as an administrator - both on the shortcut's Compatibility page and using the "Run as administrator" choice on its right-click menu, to no effect.

Same thing with setting it to run in compatibility mode for XP SP3. No effect.

I checked - I've never set Windows Media Player to monitor my library (I don't use it), and quitting Foobar2000, which does, made no difference.

Winamp, which I used to use for tagging but no longer monitors my library, can still change tags on items that were in its lbrary from before. MP3TAG reflects that those changes were in fact made.


Please check this thread
Compatibility Settings Windows 8 (UAC)
and the link to the Microsoft support page on how to change ownership.
You should add "everyone" to the files on the external drive.

Can't read German, and taking "/de" off the end of the URL in that thread didn't work.

Nevertheless, I spelunked through all "permissions" and "special permissions" buttons and tabs, starting not at the root of the drive - to avoid paths longer than 255 characters - but at the root of my music file tree - and gave "Everyone" every kind of permission and rights, and made sure that it was set to apply the changes to subfolders and files. (Nowhere did I come across any reference to "ownership" of files or folders.) Then I shut the machine down completely, in case it required a reboot to take.

No difference. As before, Mp3Tag will rename files based on tags, but will not let me edit or create tags.

If it had something to do with permissions or ownership, wouldn't that also prevent Winamp from editing the tags on the same files? Winamp has no problem.

I've tried uninstalling and reinstalling mp3tag, and even falling back to version 2.64, which is the oldest version I have - but, unfortunately, was the version with which I first noticed this problem, while still in 32 bit Win 7 (sorry if I was inaccurate about that earlier).

Is 2.63 available for download?

Update - fell all the way back to 2.39, the next-most-recent version up at the site. No difference, so it's obviously not a change in the program but in its environment.