Cannot enter special characters in Tag Panel fields


#1

Hello,

I can't believe that I never ran into this problem before, because I've been using this great piece of software for the last X years. Virtually all of my music is classical. And in this genre you run into characters with diacritical marks all the time, like: É, à, é, ô and ü.

I usually enter these characters when I rip my CD's by using the Windows keystroke Alt + digits, where digits are the 4-digits typed on the numeric keypad that correspond to the character I wish to enter. But recently I started adding custom metadata fields to the Tag Panel. The problem I found is that you can't enter the special characters into the drop-down boxes; you can paste them, but not type them.

Can this behavior be changed (Boy I hope so, or my job just got a whole lot more cumbersome)?
Thank you very much.

Bob


#2

Sorry, I cannot reproduce what you described. I can enter any Alt+4digitcode into the tag panel into any field.
It does not even seem to make a difference whether you use UTF or ISO encoding.


#3

That's strange. Let me ensure we are talking about the same thing. How about this:

And by enter I mean using the Windows keystroke combination. Pasting the special characters always works in any widget.

Mp3tag v2.94
Windows 10


#4

I just tried it with Alt-0201 in the tag panel (on the left in the screenshot) which gives É and it worked.
I saved the modification and it stayed.
So I still cannot reproduce it.
V2.94 on W10 1809


#5

Just as a try:
Could it be that you have duplicate fields in the tag panel (this should not happen any more with the V2.94 and on the screendump I don't see any)?
Could it be that the file mp3tag.cfg is somehow broken? You could test it by renaming it (to have it as a backup if this is not the cause) and then start a sort of blank MP3tag.
I can't think of much more at the moment.
Other things could be that some kind of background program catches keystrokes with "Alt" - but then it should not be possible to enter the keycodes anywhere and not just the tag panel.


#6

I cannot believe how stupid I am sometimes. I won't try to wiggle out of it. I don't just have egg on my face, I have the whole chicken's butt on it. I had the NumLock key OFF.

Hold on a minute. I just tried a little test. With the NumLock key ON you can type special characters
in any field. With the NumLock key OFF you cannot type special characters into the Tag Panel, but you can type them into the table text fields. That's the behavior I was seeing, and this latter scenario led me to believe that the NumLock key was ON. Windows, love it or leave it.

That's one to remember.

Thank you very much, and sorry for the trouble.

Bob T.


#7

I cannot reproduce this.
There is no difference with my keyboard whether I have the NumLock-Key on or off.
I can type diacritic characters with ALT and the num-keys in the tag-panel and in the the list-view.


#8

It seems to depend on the character code:
e.g. Alt-0201 and num lock off opens the dropdown list and no further input is possible.
e.g. Alt-0111 and num lock off does not open the dropdown list but creates the character.
You can also create other effects not only opening a dropdown list but switching between windows, changing directories. Funny stuff really.
I suspect: if the keycode can be generated by your keyboard anyway, then it is also entered as data regardless whether num lock is on or off.
If it is a character code that the keyboard usually does not create then with num lock on it creates a character, with num lock off it is a control character.


#9

Just a wild guess:
The numeric keypad key "0" and "1" have no "arrow down" function.
The numeric keypad key "2" has also the function to press the "arrow down" key and open the drop down box?


#10

Yes, this could be it: Alt-0130 produces a comma without opening a menu.


#11

I just use the Windows character selector. Or better yet, I create a text file and insert my special characters there.


#12

Hello again. Ok, after reading all of your posts I think that I've figured out the behavior. First some background:

  • To get a keystroke combination I used the Windows Character Map application.
  • I created and printed out a little table of all the characters that I use.
  • Virtually all of the characters are of the form "Alt + 02xx", A few of the 'A' category begin with "Alt + 01xx".

So, with the NumLock key OFF, I found:

  • Pressing the number 2 or 8 displays the values '< blank >' and '< keep >' because these two keys also function as a down arrow and up arrow, respectively (on my keyboard).
  • Pressing "Alt + 2" or "Alt + 8" opens the drop-down list (which may be the default behavior for Alt + Up/Down arrows and this widget).
  • The same thing happens if you press any one, or more, of the non-arrow keys (0,1,3,5,7,9) before pressing the number 2 or 8.
  • For example, all these keystrokes open the drop-down list: "Alt + 01352", "Alt + 135792", "Alt + 555558", and so on.

The moral of the story is, "Don't be a NumNut like me, turn on the NumLock key. :crazy_face:

Regards,

Bob