Can't access file via secure bookmark

Hi Florian,
Thanks for the greatly useful app. It's a perfect app to organize tag for my music library.
I have an issue with the app when using it on my second Macbook, though.
When trying to edit any metadata, it's said that I can't access the file on my external hard drive. I already gave Mp3Tag full disk access on Security & Privacy.
When searching here, I found someone had the same issue and solved with "defaults delete app.mp3tag.Mp3tag SecurityScopedBookmarks" in Terminal app.
I tried that several times, restart Macbook and everything but the issue still there.
It's totally fine when using Mp3Tag on the other (old) Macbook even though once in a while, Mp3Tag announced that there're some files can't access and edit tag.
My MacOS Big Sur 11.5.1 and Mp3Tag version 1.2.3 (51)
Please advise

1 Like

Hello and welcome!

Can you please try navigating to a root folder on the external drive via Cmd+O and load the files. After that, try tagging the files in one of the subfolders that didn't work before. Let me know how it goes.

Hi, thanks for the swift respond.
I tried your advice, the problem still persist, not only in that subfolder but in all files on the external drive.

OK, that's very strange. Can you give some details about the external drive, also which file system you're using there.

In addition it would be helpful to see which error messages Mp3tag logs to in the process. Can you open, turn on streaming logging, reproduce the issue and lookout for any messages from or sandboxd.

My external drive is Seagate Backup Plus Drive 6TB, using Microsoft NTFS. I can access and edit files/tags on it easily with my old Macbook using Mp3Tag.
On this new Macbook, I can edit filenames using Finder but can't do anything using Mp3Tag.

Here what I found on Console app, searching for Mp3tag

error 09:59:22.104253+0700 Mp3tag Error resolving secure bookmark: Error Domain=NSCocoaErrorDomain Code=4 "The file doesn’t exist."
default 09:59:22.104278+0700 Mp3tag Cannot access write file file:///Volumes/Seagate%20Backup%20Plus%20Drive/Classical/John%20Metcalfe%20-%20The%20Appearance%20of%20Colour/01%20Appear.flac via secure bookmark
error 09:59:22.490068+0700 Mp3tag Cannot access file "/Volumes/Seagate Backup Plus Drive/Classical/John Metcalfe - The Appearance of Colour/01 Appear.flac" via secure bookmark (accessDenied(file:///Volumes/Seagate%20Backup%20Plus%20Drive/Classical/John%20Metcalfe%20-%20The%20Appearance%20of%20Colour/01%20Appear.flac))

Here what I found on Terminal, using "defaults read app.mp3tag.Mp3tag SecurityScopedBookmarks"
"/Volumes/Seagate Backup Plus Drive" = {length = 856, bytes = 0x626f6f6b 58030000 00000410 30000000 ... 04000000 00000000 };

Thanks for the details! Everything looks good, except for the error messages. Are you also using macOS Big Sur 11.5.1 on the other Mac where the external drive works correctly?

Yes, at first I also assume if the MacOS version cause the problem but both Macbook use the same MacOS Big Sur 11.5.1, both use Intel processors. Yesterday, I had to plug the external drive to my old Macbook and can use Mp3Tag from there perfectly.

I'm having the same issue OP is describing. I hadn't used the app for a few weeks/months and today it gave me that error. I used your Cmd+O suggestion and it didn't work at first but it must have been because of what directory I selected. I chose one in my user directly and then it asked for permission, now it is working. this was on my mac, not external drive. (Apple Macbook Air, silicon/m1, big su 11.5)

adding folders other ways didn't trigger the permission prompt.

I've experimented a little bit regarding this issue and it seems that macOS Big Sur has only read access to NTFS drives by default. I'm still a bit unsure about that, but this is was my experiments show.

From what I've researched, there are plenty of vendors that offer NTFS drives for macOS and given that you're able to write to that filesystem, I'm assuming you have one of those installed in your system.

Assuming my analysis is correct so far, is it possible that the problems result from two different versions or vendors of said filesystem driver?

I installed the same software on both Macbooks: Microsoft NTFS for Mac by Paragon Software, same version 15.8.108.
It's very strange!
I have to continue using the old Macbook to edit tag, working fine except 1-2 tracks can't edit out of few hundreds tracks (still don't know why and how to fix)


I am encountering the same issue wile trying to edit some tags. What I can tell:

  • Using MacOs Monterey (12.2.1) on Apple M1 Pro
  • Editing ALAC files (m4a)
  • Files are on the local drive (that is, not NTFS)
  • Files, parent folder and tags can (but not always) contains Japanese chars
  • It sometimes saves edits, only if I do save file by file (or in bunch of 2 or 3 files)
  • Renaming files after tags also trigger the issue

Can you try this command via while Mp3tag being closed:

defaults delete app.mp3tag.Mp3tag SecurityScopedBookmarks

After that, load the folder (not the individual files) via ⌘O and see if the issue persists.

Ola Florian, I will try this morning.

I made a few more test I'd like to report:

  • Moved the albums both in Downloads folder and retried: Some worked and some other did not :negative_squared_cross_mark: (My guess was Music App is watching and locking its catalog content)
  • and in a folder on my NAS (Samba): All worked :white_check_mark:
  • from the NAS, I also tested on a Intel Mac (same OS version) :white_check_mark:

It might be related to 1.) how you load the files and 2.) which changes you perform.

If you load the files individually, e.g., by using drag and drop from Finder or, Mp3tag gets secure access to the files but not to the actual folder of these files. If you then perform a change that requires secure access to the file's folder, i.e., renaming files or performing changes that require a temporary file (e.g., adding large cover art), Mp3tag runs into that issue.

So if you load the files via the folder or maybe even a higher level folder (e.g., ~/Music/), Mp3tag gets secure access to all its containing files and remembers this via a secure bookmark.

You are right, I essentially add files via d&d. I tested as you say

Before CLI

  • Opened via Open file Menu and edited :white_check_mark:
  • Opened via Drag & Drop and edited :negative_squared_cross_mark:

After CLI

  • Opened via Drag & Drop and edited :white_check_mark:

Side notes: Confirming what you said, drag and drop folders or individual files doesn't change the issue.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.