Can't download app for Mac

I'm on a MacBook Pro running Ventura 13.4 and I can't seem to download your app for the free trial or even buy it on the app store. Just wondering if I'm doing something wrong or if you don't support this OS version. Thanks!

Can you describe what's not working? Usually, downloading from

should do the trick. macOS Ventura is supported (and everything back till macOS Mojave).

I tried again and the same thing happened...Then I had the idea to switch browsers. For some reason it worked with Firefox but not Safari. Thanks!

Glad you got it working!

Out of interest: do you use any Safari extensions which might interfere with that?

1 Like

Not that I know of...Ad Blocker maybe?
I just tried opening the app again and got a message saying that I need to buy it, but I got a receipt from Apple the other day saying that I already paid the $19.99. If you can help with that next I'd appreciate it! Thanks, Ed

There are two different options to purchase Mp3tag: one is via the Mac App Store and the other is via my website.

Only the latter requires a license key. The App Store version doesn't require a license key, because everything is done via the App Store system.

So if you bought Mp3tag through the Mac App Store, just delete the standalone-version from your Applications folder and go to your purchases in the App Store app via ⌘0. From there, you can download all your apps you've bought through the Mac App Store, including Mp3tag,

Great...Thank you! That seemed to work.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.