cant read m4a file / cant open file for writing

I had (i think id3v1) tags in my files, i then used itunes to download cover art and embed it using scripts.
the cover art worked in itunes and nokia music player, but not on my 5800 symbian 60v5
So i tried to use mp3tag to see if i could fix the tags.
a couple of problems:

  1. cant read the tag on m4a file
  2. cant open file for writing when i try to edit tags
    I've already fixed it using mediamonkey, which could read the tags, and saving it with mm fixed the problem

I'm posting here in case it is a bug or helpful to someone else can someone tell me what is wrong in the file? using latest 2.46a build

is it related to cover art not having a "cover type"?
does it have multiple tags in there?
here are the two files, working and not working
link removed
cheers,
Ben

Non working file has ID3v1 tag at the end of the file. Mp3tag can't handle that.
The other file also has an ID3v1 tag at the end but the tag is little broken so somehow that works.
But it's not really clean.

thanks dano, an tips on how to clean the tags up?

When you change the extension to .mp3 you might be able to remove the ID3 tag with the "Remove Tag" command.