Can't remove multiple APEv2 tags

I have some MP3 files which are reported by MP3Val to have multiple APEv2 tags in each file. I'm trying to use MP3Tag to remove them, but getting nowhere.

I have gone into Mp3tag Options and checked all options for both "Read" and "Remove." (I don't care if it also removes the ID3 tags, since I'll be overwriting them from a text file anyway.) I've also tried it with all "Read" selected and only APE selected for "Remove." With the files selected, I've tried both Ctrl-x and the :x: button up by the Edit menu. No matter what, the tags still seem to be there.

How can I get them removed?

It could be that if you have several layers of APE tags that you have to repeat reading and deleting several times until the stack of APE tags has been removed.

I think that MP3val reports APE tags as "Garbage at end" - so perhaps several rounds with MP3val may also help.

I would try the following settings:
ON to read and delete APE tags .
OFF read, write and delete for all other tag versions.
Re-read the files with these settings,
select "Delete tag" - and watch the column that shows which tag versions are in the file(s).

I've tried multiple rounds with MP3Val, but hadn't thought to try multiples with MP3Tag. I'll give that a shot.

Unfortunately, that doesn't seem to have an effect. The "Tag" column in MP3Tag is empty, though. So maybe MP3Val is just mis-reporting?

Could be ... there is also MP3diags, perhaps you try that tool as well. Not all tools serve all purposes.

If you turn on reading V1 and V2 tags again - does the column show something different or did you delete really all tag data?

Well, I had deleted it all. But when I put something into a tag now (after turning those on, that column shows ID3v2.3 (ID3v1 ID3v2.3)

Sure enough, there were tags there. MP3 Diags read them, and removed them. First time using that program, but it worked great.

Thanks for the tip @ohrenkino!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.