Can't rename directories in vm

I have been using mp3tag for a long time on windows without any problems. I have recently switched to Mac and I'm using VmWare fusion to run windows xp to run mp3tag. So far everything works, except the directory name change.

I'm using %format value% on _DIRECTORY to change the directory to %artist%\%album% or %album%, but I always get an error the the file doesn't exist.

The drives are mapped to xp machine where mp3's are stores. What is the reason that I can't rename directory like I could in windows. Is this a disk format issue?

afaik are the conventions for addressing directories different in windows and mac OS: windows uses the backslash and mac os the slash.
So it is now a question how good the vmware hides the path conventions.
IS mp3tag the only application that causes trouble?

I have tried both backlash and forward slash, but it doesn't work. So far, mp3tag is the only application that does that. I don't have any other application to test renaming feature. I wish there was another program that could do that, but I don't know of any other.

You could try the good ole DOS command shell and enter a command like:

copy \oldpath*.mp3 \newpath

This assumes that you have a test-folder oldpath and one called newpath (manually created with the vm explorer) both right beneath the root layer.
It also assumes that you have at least one mp3-file in the directory oldpath.

And another thing (no, not that!): do you use relative or absolute paths?

In a VMware forum I found the advice to address shared directories as network paths.

(I have to ask all these questions as I do not have this setup. If you want me to shut up, tell me so)

I tried

copy \oldpath\*.mp3 \newpath

and it worked just fine.

I have the shared drive mapped under a letter z:
But when I try to change the name of the directory within mp3tag, it gives me error.

Basically the current directory name is "Artist - Album Year" and I am trying to change it to "Artist\Album". This worked when I was using Windows as my main OS. This is the reason I posted this. I want to know is this different when using mapped drives, because as far as the OS is concerned the file exists at z:\music"Artist - Album Year" and it should be able to format it.

So is this a bug or not? I can check or try more things, if needed.

Have you tried to use the networkpath with the double-slash in front?
What does the support for VMware say to accessing shared paths?
As teh commands work fine with "normal" windows this hardly looks like a bug in MP3tag but like a peculiarity in VMware ...

What happens if you use the converter Tag-Filename in MP3tag and relative path settings?

How do I change that setting in mp3tag?

This is my limited English ... sorry!

I tried to express the following:

if you use the converter "Tag-Filename" and enter a mask that in fact creates a relative path then this should act just like the command to create a new directory:

%year - %album%\%track% _ %title%

would create a folder with the year and albumtitle plus a file with the structure track _ title.

The question is: does this work?

Yes! this works fine. I never thought of it this way. But I still think it is a bug when this works fine. I still can't do it using format value.

Thanks for the suggestion. I'll back to tagging my music now.