Certain .m4b files to not be recognized in mp3tag

I have been trying to go through my audiobook collection and add a bunch of tags for better library management, but about 1/3 of my files are not recognized when I open a directory. Some of these files have come directly from Audible, via the OpenAudible program - so it gets the Audible files and converts them to .m4b. I then copied those files over to my library and used Readarr to rename/reorganize them. Now, some of them show up in mp3tag, and some of them don't. I cannot figure out what happened to some of the files in the 2 days since I put them in their folders (I just downloaded all of them with OA 2 days ago). I can go to my OpenAudible directory and re-copy a file to my library, and it will be recognized. If that was my only source, I would just redo everything, but more than half of my books are ripped from old CD's so I can't recreate the original files...

I have to suspect Readarr because it is the only program that altered the files. I can't seem to reproduce the issue though. If I put a new file in, and it is recognized, nothing I do with Readarr seems to break mp3tag.

Other facts to note:

  • I have a fresh installation of mp3tag as of this morning.

  • When I open my top level library directory in mp3tag, the progress window shows: "reading data ## of 367", but when it finishes, there are only 211 files showing.

Any ideas?

Check if you have accidentally applied a filter.
Press F3 to toggle the filter window.
See if all the files appear when the filter is off.

No filters active, I did check that. Thanks for the suggestion though. That was the only decent recommendation I was able to find by googling the issue.

So, the filter window at the bottom is hidden and you still don't see the files?
What does the status bar say? Does it show just the number of files? Or something else?

In case the image isn't clear, I don't believe there are any filters to speak of, and it shows a number of files (not sure why the most recent scan yielded 232 files, and not 211 like the last few times...).

The screendump shows that the filter is still shown and therefore potentially active.
But: the status bar shows just a plain number (in this case 232 files).
None of the files is selected.
And no files are hidden - otherwise you would see something like 192/232 which means that 232 files are loaded but only 192 are displayed.

And as you now find a different number than the one that you expected, I would say that you have to check which number is correct.

Sorry, I just pressed F3 to show that there were no filters. Prior to your question, the filter view was never there (brand new install a couple hours ago and all I've done since then was add a couple columns for series and series-part).

A brand new install shows the filter section by default.
But you are right: currently the filter does not lead to hidden files - as can be seen by the numbers in the status bar.
So, now you have to watch whether the number of initially prospected files matches the number of eventually loaded files.
You could press F5 to reload the selected folder(s).

Good to know on the fresh install.

I've refreshed quite a few times in the past 20 minutes, and no change to the number of loaded files. Still 232 out of "reading tag data ## of 367"

My initial thought was - is it possible there is something in the tag data that is incompatible with mp3tag or something. Is that possible? For one of the files, I tried to completely delete the tag data, but I'm not sure if I was successful. Either way, it did not make the file load in mp3tag.

Then I cannot help you any further. Or the other way round: I cannot reproduce this behaviour.
On my PC the number of found files matches always the number of loaded files. The number of displayed files may vary if there is a filter. But we found out that this is not the case this time.

Alternatively, you could load one folder after the other and see if the numbers of found and loaded differ. Or if there is a folder that causes problems. But that roughly a third of the files is ignored ... no idea.

I appreciate the effort. I've loaded many of the folders, and from what I can tell, it is always the same files that don't load, and they are spread out across a large number of top level folders. It seems like the files are the issue - I can move a file from my library/server to my PC HDD and they are still not recognized. If I right click on a single file and select the Mp3tag option (with the program closed to start), it will open the program and show 0 files.

Is there any way to produce a debug log for a directory scan?

Or here is a wild guess:
There is an option to show chapters as separate files.
See Tools>options>Tags>Enhanced
whether that makes a difference.

If you see a file that does not load - could you supply that or a screenshot of its properties?

Showing chapters as separate files did not change whether the missing books would appear.

I'm willing to share a file or properties. Any specific properties I should show?

I think that a whole file would be best

Can you isolate one or two files that are not showing up in mp3tag? Maybe you could share that file and we can try from our side.

These files aren't small, but I can share. Best way to share a .m4b file? If I try to upload it to my message, it says it's not an approved type. I guess I could change the extension...

Well that brought up an interesting idea. If I change the file extension to .mp3, it loads the file as far as to show an mp3 header parse error.

Change to .mp4 and it does not load.

You could try Foobar200 and its utility to check the integrity of the file and see whether there is something wrong

I'm curious what you'll find. I put 2 copies of the same file in there. One is straight out of OpenAudible, and the other one is from my library - started as an exact copy of the first file. If I load the directory, I only see one file.

https://drive.google.com/drive/folders/1BGSuOtjVsO1ClKfZnUEqYwjRfIH5t_j-?usp=sharing

The file with the extra data in it has 2 extensions, m4b followed by mp4. I suspect this is the one that has been "converted" and I would look into that software first. The other file opens correctly and shows the metadata as expected.