Change Directory & Add Directory no longer working

Hope everyone here is safe and well!

I see some other posts related to my issue, but most are more than a few years old.
I believe the issue started with v3.01, but have not tried rolling back yet.
I am having this problem on a machine still running Win7 x64.
All toolbar functions and their respective File menu commands work, except for Change & Add Directory.
I tried installing v3.01a on another Win7 x64 machine and everything works fine.
No doubt this is some kind of Windows issue, and considering Win7 is EOL, I don't expect it to get looked into. However, I'd like to see if anyone else has experienced this and and has any direction.

Thank you!

What does "does not work" look like?

No action whatsoever when clicking either the Change or Add Directory buttons, or choosing those functions from the File Menu. They 'press', but not getting a file dialog box like you would normally.

Perhaps your mp3tag.cfg file is corrupt, rename it while MP3tag is not running and then try again.
I doubt that this is W7 specific (I have a W7 installation that has no such problems) but a local one on that particular pc.

Thanks - I tried that already - aside from all my settings reverting to defaults, no change.
I did also start having a similar issue with another program that uses MS Visual C++ and .NET.
Pretty sure Mp3tag uses Visual C++ Runtime Libraries, but does it also use .NET?
I may start by removing the many Visual C++ versions and reinstalling as needed.

No .NET used in Mp3tag.

It’s all pretty standard and it’s weird that the open directory dialog is not showing up for you.

Thanks @ohrenkino & @Florian - As I am about to build a new Win 10 box to replace this one, I didn't want to spend the time uninstalling/reinstalling all of the Visual C++ builds and figured no harm in trying an in-place upgrade/repair install. This completely resolved the issues I was having, so I'm at least back up and running until I get the new machine online.

1 Like