Change directory without Explorer


#1

I've been using Mp3tag for a while. I recently bought a Synology DS218 and installed all my music on it. This NAS does not appear in Windows Explorer. I've spent hours in communication with both Synology and Windows trying to get this fixed, to no avail, though Synology says their next software version MIGHT contain a fix. I can play music using the Synology Audio Station and rip CDs using dBpoweramp, but I can't reach the music files using Mp3tag because the only way to do so appears to be via Explorer. I tried searching in Mp3tag for SynologyDS218 (that's the name I gave the NAS), but no luck. Is there a way I can load files onto Mp3tag without going through Explorer? CT


#2

Can you assign a drive letter to the folder on the NAS?


#3

Thanks for your quick response. I've tried to assign a drive letter using Map Network Drive in Explorer but as the NAS doesn't appear on my home network in Explorer I can't do that.


#4

AFAIK a NAS runs fairly often some kind of Linux SW.
And AFAIK, you have to start a service called Samba on the NAS that introduces the NAS to a windows network.
As you said

I thought that you have some kind of access. So what do you mean by that?


#5

I'm not aware of Linux or Samba being involved.

I can access the NAS by typing the IP address into Google. And I can rip CDs to it via dBpoweramp by typing in \SynologyDS218\music. But this doesn't work with Mp3tag for some reason.


#6

the proper syntax for a network device would be
\\SynologyDS218\music
but this usually only works if that server is visible in the network.
So if access to your music files is the main application and that does not work, then I would return that NAS.
I have to stop now because I cannot give you any reasonable advice.


#7

There's nothing wrong with the NAS. I tried it on a different PC and it was recognised. What I need is a workaround for Mp3tag so I can type in the file address rather than going through Explorer. But maybe that option doesn't exist?


#8

What is different on the other PC?
I would setup the blind PC (the one not seeing the NAS) in the same way as the clairvoyant one.
Mp3tag uses the functions of the OS to address files. If the OS cannot access the device, so can't MP3tag.


#9

Yes, this option doesn't exist.

Mp3tag is capable of handling files on normal drives that start with a drive letter, e.g., C:\ or network shares that usually start with a double backslash followed by the server name, e.g., \\Server\Share

It's kind of strange that your system doesn't pick up the device, but from looking at the respective category on the Synology forums, you're not the only one:

https://forum.synology.com/enu/viewforum.php?f=49


#10

@charlest33 You should check this Synology article, especially the "SMB Advanced Settings" part:
english: https://www.synology.com/en-global/knowledgebase/DSM/help/DSM/AdminCenter/file_winmacnfs_win
german: https://www.synology.com/de-de/knowledgebase/DSM/help/DSM/AdminCenter/file_winmacnfs_win

Windows 10 has introduced a new "security feature" with one of the latests updates and prevents to access network devices using the old (and unsecure) SMB1 protocol.
More information:
https://support.microsoft.com/en-us/help/4034314/smbv1-is-not-installed-windows-10-and-windows-server-version-1709
and
https://support.microsoft.com/en-in/help/2696547/how-to-detect-enable-and-disable-smbv1-smbv2-and-smbv3-in-windows-and

Therefore you should change your settings on the synology accordingly.

You can also try to adjust your SSDP settings:

The SSDP service allows users to find the Synology NAS via Windows network discovery.

BTW: If you can access the same Synology from another PC, I assume, this other PC has not the most actual Windows 10 with latest patches installed?


#11

Many thanks for your suggestions. I've tried pretty much everything on the Synology site but nothing seems to help. I think I'll just wait and hope they provide a fix in the next update. Fortunately I can access the new NAS using Mp3tag on my old laptop so I can still edit my tags. Thanks again, CT


#12

I have exactly the same problem on my PC, also with Synology DS218. I have not allowed Windows to update my laptop to Windows 10, specifically for the purpose of using mp3tag. Pretty ridiculous! Hoping for a fix in the not too distant future.


#13

Do you have adjusted the settings on your DS218?
I use several Windows 10 machines with several Synology Models. They all work great with Mp3tag if you do the listed changes.


#14

In Synology I went Control Panel > File Sharing > File Services > Advanced and enabled SSDP and WS-Discovery, which didn't help. Is there something else I should do?


#15

Yes: Try to set the SMB minimum protocol to SMB1 or some level which works for you.
You can do that on the Synology or - as last resort - on your windows machine.


#16

Many thanks, that really helped! I changed the SMB minimum protocol from SMB2 to SMB1 (left the top limit at SMB3). I can now use mp3 on the PC most of the time. Synology appears in File Explorer about 90% of the time, which is a definite improvement.