Change Field Format in pone discogs script


#1

How do i configure the Performer Field to align like the Credit field.

Discog Performer field looks as follows after tagging:

A1 Best Of My Love

Bass – Verdine White Drums – Fred White Synthesizer – Larry Dunn Written-By – Maurice White Written-By, Guitar – Al McKay 3:40

A2 A Feeling Is

Bass – David Shields Drums – James Gadson Guitar – Marlo Henderson Written-By – Sheila Hutchinson* 

Would like it to align like the Credit field as follows:

sample: http://www.discogs.com/release/1086664

Best Of My Love

Bass – Verdine White
Drums – Fred White
Synthesizer – Larry Dunn
Written-By – Maurice White
Written-By, Guitar – Al McKay

A2 A Feeling Is

Bass – David Shields
Drums – James Gadson
Guitar – Marlo Henderson
Written-By – Sheila Hutchinson*

Thanks


#2

If you use the pone script 4.0 then change the tag ARTIST NAMES of the settings file.

Got the line
Extra Artist - Track Credits - Name Variation: >MIXARTIST

a few lines below you find
- multiline tag field >no

change it to
- multiline tag field >yes

and create the scripts again.


#3

Got it... works great...

Thanks


#4

Pone / Dano I would like to know if it's possible to make (2) modifications to the Web Script Settings:

  1. The Credit tag witihn the Web Script Settings. How to remove the word: Credit from the Web Script update. I can do this manually, but I have to go to each *.src

#< ## ALBUM CREDITS - Main Section #
findinline ""albumextraartists":" 1 1
if " [{"

outputto "CREDITS"
say "\\\\u000d\\\\u000a"  (Notice I have removed the word <i><b>Credit</b></i> after Say"                 
  • (However - obviously - each time I update the Webscript it adds it back in to the new script.)

Is there a way within the Webscript to make the change.

  1. How to modify the Web Script to add a Broken line after extra artist name (role) .

Extra Artist - Track Credits - Name Variation: >PERFORMERS

  • name/role format: >role: name
  • combine names with same roles >no

if more than one extra track artist:

  • multivalue tag field >no
  • multiline tag field >yes
  • list of names >yes
    • seperating characters used in list >;
      Extrafields: >
  • delete extra fields from main section >yes

Example:

Album Credits:

Stanley Clarke Bass/ Vocals

George Duke Piano, Keyboards

Todd Cochrane, Steve Hunt, Deron Johnson Keyboards

Howard Hewett, Alexis

Thanks


#5

In the setting mp3 file of my discogs web script, go to:
CREDITS; NOTES; IDENTIFIERS; COMPANIES
At the begin, use the following settings:

Combine Credit fields with other fields:

  • Track Credits Primary Names >no

  • Track Credits Name Variations >no

  • Album Credits Primary Names >no

  • Album Credits Name Variations >no

(If credits are combined with other fields, the script uses an extra headline (the word "Credit:"), if not combined, there is no headline)

Note that there are two different credit/extra artists sections at Discogs: track credits and album credits.
The settings you have posted are for the track credits:
Extra Artist - Track Credits - Name Variation: >PERFORMERS

But your example are album credits. For those, go to
Extra Artist - Album Credits - Name Variation:
(also in the ARTIST NAMES field of the settings file).
There, use the following settings:

if more than one extra album artist:

  • multivalue tag field >no
  • multiline tag field >yes
  • list of names >no

    Edit:

    I think i misunderstood you. I thought you want a line break. But you actually want a broken line like this: - - - - - - -
    I experimentated a little with the script and found out that it is possible. Use the following settings:

if more than one extra album artist:

  • multivalue tag field >no
  • multiline tag field >no
  • list of names >yes
    • seperating characters used in list >\u000A------------------------------------\u000A

#6

Thanks for the quick response...

#1 - I got fixed immediately.

#2 not so easy... like you, I've tried different variations, but can't get it to format correctly.

http://www.discogs.com/release/2062386 (Stanley Clarke)

Here's what I get:

Backing Vocals: Dee Dee Bridgewateru000A------------------------------------\u000A
Drums: Darryl Brownu000A------------------------------------\u000A
Drums: Harvey Masonu000A------------------------------------\u000A

Which again I would like to look as so:

Backing Vocals: Dee Dee Bridgewater

Drums: Darryl Brown

Drums: Harvey Mason

Electric Bass, Bass Guitar [Piccolo], Talkbox, Vocals: Stanley Clarke

It Seems there should be a way to insert a line break ---------------------- after any ;

Not a major project, but if you have another idea let me know. Currently, I'm doing it manually, but that gets old quickly.

Thanks


#7

It works for me, I have tested it.

What Mp3tag Version are you using? Your forum profile says 2.45, which is pretty old.
I think \u000A for linebreak was introduced in one of the latest updates. In older versions, you need \\000A, but that is not possible with my export script, because \\ generates a mulitvalue tag field in Mp3tag.

You could also test u000d\u000a but I think that won't work either


#8

it works... Had to update version...

Thanks