Comment in itunes


#1

Hi I have been using Mp3tag to synchronise all my files. I also use ITunes as my "database". My problem is now that the "comment" field in Mp3tag (commentaar with me as I use the Dutch version), can't be read in the "comment" field in Itunes. Any idea what the reason is and especially: any idea what I can do to solve this?


#2

Dear franss,

I've just analyzed the iTunes comment tagging and comment reading and discovered, that iTunes only reads comments with the language descriptor set to ENG. Mp3tag always writes XXX as language descriptor, since it is the default of the tagging library 'id3lib' and since there are users of many different languages.

Best regards,
~ Florian


#3

Thanks Florian, for this reply.
Is there a possibility to set the language to ENG then? That would solve the problem I guess. Or am I wrong.

f.


#4

Hi franss,

can you please try comment tagging with the latest Development Build?

Best regards,
~ Florian


#5

Hallo Florian,

First I've reinstalled the "normal" 2.18 version, now using english as standard language. This didn't work with the comment field. I saw that field the way I filled it in, as "commentaar", but itunes still didn't recognise it. But after resaving the files it worked fine. Next I tried teh Development Build as you asked me, but that worked the same as above. But hey, I can live with it now :wink:

F


#6

Seems that I was using an old version of iTunes to reproduce this error. I've no problems displaying comment fields tagged with Mp3tag in the latest release of iTunes and therefore reverted the changes made to my tagging library and switched back to V.2.18b.

~ Florian


#7

I'm using 4.2.0.72. The comment thing works now for me, but only with comment added (or saved) using the english version of Mp3tag, not in the dutch version. But still, it works. Thanks again for your efforts.
F.


#8

The used language has no effect on comment writing. Please try the dutch version again.

Best regards,
~ Florian


#9

No, doesn't work for me. What I added in the field "commentaar" is left blank in the "Comment" field in Itunes.
F


#10
QUOTE (franss @ Mar 5 2004, 12:06 AM)

No, doesn't work for me. What I added in the field "commentaar" is left blank in the "Comment" field in Itunes.


What version are you using, when you're using the dutch version. I've installed current V.2.18 with dutch language enabled during the installation and have no problems writing a iTunes-compatible "commentaar"-field.

~ Florian


#11

Florian, I'm totally puzzled now. Deleted the Development Build version, reinstalled V.2.18 (in Dutch) and it works fine. But that was the situation I started with, and then id didn't....
But it looks now everythink works OK.
F


#12

Fine :slight_smile: