'Comment' tag not being displayed within 'comments' tag in windows

Hi,

I have just spent hours putting comments in the 'comment' columns of my MP3s using mp3tag and I find that they are not displayed in the properties 'comments' area of the the file in Windows, nor in the 'comment' section of MP3s in tag editors on my Android phone ('Pimp my Music' and'Mp3Edit'), after transferring the files to my phone.

The comments I leave ARE reflected in Mediamonkey in the 'comment' section, but I need this information in the 'comments' column in windows and my phone (and everywhere!), not just in Medimonkey and MP3tag.

MP3Tag and Mediamonkey seem to be processing/displaying a different tag than do the android taggers and the properties section of windows :flushed: !! Are they different tags, albeit with similar names? If so, how can I transfer these tags so that windows and Android taggers show them in its comments tag for the file?

Im using MP3tag 2.65a with Windows 8.1 64bit, and 'Pimp My Music' and 'mp3edit'. on Android The tags in the files are ID3v2.3.

Thanks,
Dale.

You have to set the variable
_M_STR_ID3V2LANG eng

to your local system's language.
The setting above sets the variable to English. This is the default setting for iTunes as iTunes always expects English comment fields.

You find the variable in the "lang" folder of mp3tag. Look for a file with the name of the GUI language that you use for mp3tag. E.g. for German it would be german.lng
It is a plain text file and can be edited with the Windows editor.
You would have to rewrite the tags, though.

As far as I can see, everything is already set up as you describe:

  • Mp3Tag's language is already set to 'English';
  • Windows local display language is 'English (United Kindom)';
  • In the .lng file for the language of MP3Tag (English.lng) the '_M_STR_ID3V2LANG' string is already set to '_M_STR_ID3V2LANG eng'.

What's wrong with that configuration?

Does the language of the Mp3 files themselves have to be set somehow as well?

:huh:

You leave me a little clueless.
No, you can't set the language of an mp3 file.
It is actually only the comment field (I think) that has a special language token. The subtitle or lyrics field have these as part of the data ...

Hi,

same problem here. Tried the thing above, didn't work. Or maybe I was just doing it wrong, I'm not particularly skilled in this field.

My system language is Czech, so I changed the _M_STR_ID3V2LANG cse "variable" to eng in the "Czech" language file, it didn't help. I ran mp3tag both in English and in Czech, same results.

Interestingly, though, when I add comments in Windows, they show up in the comment field like this: mp3tag comment\\windows comment, and when I open the extended tags window, there's two "COMMENT" tag fields, one for each of them. However, when I just click "save tags", they disappear in Windows again. Not sure if this helps.

I've read another thread on this topic, but it doesn't seem to have been resolved yet.

Thanks,
M.

Actually, it is the other way round: the default setting in mp3tag should be English for comment as this is the requirement by iTunes - iTunes only shows English labelled comments.
The local explorer expects comments in the local system language - so "cse" should be correct for a Czech windows. Czech, BTW should be used as display language for MP3tag. If you use a different language then you have to modify that language file.

Could you check one set of files for test purposes with MP3val then add a Czech comment and see what the Windows Explorer does? Sometimes WE does not read tags correctly.

Thanks for the reply.

Well, all the settings are back to default and mp3tag language is set to Czech. I checked all the respective files with mp3val, it found some problems so I fixed them, but Windows still won't recognize the comments I save with mp3tag.

I have Windows 7 by the way.

I can confirm this behaviour.

Comments saved with Mp3Tag don't show up in Windows-Explorer
Comments saved with Mediamonkey show up in Windows-Explorer

Windows 8.1
MP3Tag 2.69a
Mp3Tag-Language: German
Windows-Language: German

OK. But which string do you have in the German.lng file for
_M_STR_ID3V2LANG
?
The default is
_M_STR_ID3V2LANG eng
This is OK for iTunes but not for Windows Explorer
For a German Windows you would have to put
_M_STR_ID3V2LANG deu
and save the comment.
The newly saved German token comment should be visible in the German Windows Explorer.

Which tag-type?
ID3v2.3
ID3v2.4

DD.20150404.1112.CEST

@Ohrenkino
Yes, changing _M_STR_ID3V2LANG to "deu" did the trick.

@DetlevD
Id3V2.3

BTW i got really confused the last hour because I noticed during testing that I cannot edit/change ID3-Tags in Windows-Explorer for some of my mp3s anymore. Till now I cannot find a reason or a logic system why some are editable and some are not. The actual user is owner and has full rights and there is no write-protection enabled.

Old topic, same issue ... :slight_smile:

Anyways, I have an identical issue as the original poster, I made a lot of comments to a large number of .flac files by filling the "comment" tag, but on Win10 file explorer detail view I can't see anything under "Comments". If I right click file ->properties under "details" tab the "comments" is empty but under "ID tags" I can see what it should be under "comment"

My Win10 language is Norwegian and mp3tag was English. I tried applying the _M_STR_ID3V2LANG fix, but I can't even find this specific string under any of the .lng files! Maybe something changed in this last few years? I have the latest version installed, 2,95 I believe.

Any ideas? Appreciate your input!

Indeed: see Tools>Options>Tags>Enhanced
There you can set the language now without the need to edit the language file.

1 Like

Thanks ohrenkino!

I don't know why but I can't select any languages other than "eng" on the drop-down menu. Can I add other languages here? Even if I succed here would I have to add comments again? It's 2000 files so really I would like to avoid this! My Windows installation language is Norwegian.

I forgot to mention that all of this comments issue are with .flac files, and when I converted all of them to .m4a (core AAC), all the comments were properly displayed! Tried with .mp3 and same issue as with .flac.

Also, when I add comment under ID-Tags tab by right click file -> properties it doesn't automatically appear under comments in details tab nor detailed view with .flac files, but it does with .m4a files!

FLAC support by Windows is rather sketchy. So I would not use that as touchstone.
You can enter any 3-letter-language code in that field. I would assume that "nor" would be right for you.

oh, it's simple as that, thanks! :slight_smile:
But yeah, doesn't really help, have read a lot about FLAC issues with windows. Tried to remove native support and add external but doesn't help.