Convert Flac files to ALAC on MAC

I am very much a newbie. I recently got a NAD M33 integrated amp that works with Blue Sound/BlueOs app. I recently downloaded flac files of my one of my favorite very old albums from 1971. The BluOs network sharing uploaded the album, but with no artwork or any other information. So I used this app to find the information on Discogs. Reloaded the network sharing file, and the album not there. Searched MP3TAG and found a post from Florian saying that Apple Macs don't work well with flac files. So I downloaded X Lossless Decoder and converted the files (only 2 - side 1 and side 2) to ALAC. MPT3TAG tried to name the 2 files after tracks, so I fixed that. Then I reindexed the network file share and voila - album art and each file named Side 1 / Side 2. Thank you so much!!

1 Like

Many thanks for sharing your success! This is encouraging feedback and possibly helpful for other folks.

Some minor comments

This statement can be narrowed down to and Finder, which both have zero to suboptimal support for FLAC. FLAC itself can be used without problems on a Mac — there are, e.g., Doppler, foobar2000, and Swinsian which have superb support for playing FLAC.

I don't have a BlueOS device (although the people at BlueSound should send me one, given how many support conversation I have around their devices), but FLAC is supported by BlueOS.

If your device doesn't list files that appear to be properly tagged in Mp3tag, I'd first try reindexing and, if that's not helping, rebuilding the index.

Yes, I tried reindexing and then rebuilding the index, but didn’t see the album at all. That’s why I converted to ALAC. It is possible that in using the Flac files I either didn’t wait long enough or had to redo file sharing on the Mac but I don’t think so, as those were the first things I checked after the failure. I subsequently used MP3Tag for an even older recording (1955) and found I did need to redo the file sharing for that one. That was already

an old iTunes file. So I skipped the XLD step.

Just tried again with the Flac files. Had to redo file sharing permissions for the new folder containing the Flac files on the Mac. So far, they are not uploading to BluOs.

I think I just had to wait awhile for the Mac sharing permissions to take effect. I now have the flac files uploaded with correct tags and artwork. FYI, I posted my original comment on BluOS community and one of their techs recommended Bliss. I checked that out and for my needs found it to be less useful than MP3Tag.