Cover Art Directories

This definitely does not work as advertised.
In Tools-Options-Directories I have left the Cover Art directory blank. This should mean that mp3tag will look in the same directory as the first music file for the cover art, which it used to.
Now it looks in the directory specified in File-Change Directory.
This is an absolute pain, and has probably trebled the time it takes to edit music files properly.
Please fix!!

Thank you

You can enter %_folderpath% as directory until it is fixed.

I doubt the developer will fix this. The development history says:

[2012-07-19] REL: VERSION 2.52 (for Windows XP/2003/Vista/2008/7)

[2012-07-19] NEW: added option to specify default directory for cover art.
[2012-07-19] NEW: added preferences page for directories used in Mp3tag.

So you can use a place-holders like the examples below:
%_directory% Name of the parent directory

%_folderpath% Path without file name

%_folderpath_rel% Folderpath relative to Export output file if output and track files are on same drive, else absolute

%_parent_directory% Name of the grandparent folder

%_path% File name with path

%_volume% Volume label

%_workingdir% Name of current working directory

Path of current working directory

Hmmm. Or at least I thought you could. I tried changing it to %_volume% and %_parent_directory% but it brings me to the %_folderpath% everytime.

Anyone else have this problem?

It contradicts what's written in the help file. So one of them needs to be fixed.
And what's written in the help file makes more sense.

%_volume% is just the volume label and not part of the file path. So I don't see how that should work for a cover path. If you keep going back to %_folderpath% it means you built an invalid path with your placeholders.
What path do you want to get?

True that.

Volume should bring me to 'F:' for example. Anyway, I was only testing to see if it works and it doesn't. Personally I'm just using an absolute path so that works fine.

%_volume% returns the name of a drive - not the drive letter.
Test the output with Convert > Tag - filename

To get the drive letter you'd have to use something like $left(%_path%,3)

I agree that when the designated cover art directory is blank, Mp3tag should give the old behavior of using the folder of the first selected file. It shouldn't be necessary to enter some obscure variable here to get the expected behavior.

I'm really surprised that the 2.52 installer didn't clear this setting instead of keeping the directory that was last used. It's going to confuse many people in the future, as the casual user won't be aware the setting exists and will wonder why Mp3tag keeps opening the same oddball directory.

It certainly confused me! Just saving the last folder you used as the default is the stupidest choice possible. It would be polite to warn people about such a large change in behaviour.

I'm probably speaking way above my pay grade here, but just wanted to express my annoyance at the tone of entitlement some of the posters here appear to exhibit.

It is of course helpful to the project to point out inconsistencies and unexpected results, but IMO it isn't appropriate to word things as complaints and demands as if you're a paying customer.

This is a tremendously valuable piece of software we're all using for free here and benefiting from the valuable time other users are contributing here for free, and making suggestions and polite requests with regular expressions of gratitude for these facts will surely help make it more pleasant for those on whom we "mere consumers" depend.

/end rant

I agree, more gratitude, less attitude.

And as I've mentioned before, if we are using this AWARD WINNING product so often that this change is truly an annoyance, shouldn't we be making a donation to help support the effort? The next best product that does this work goes for $30 USD and it's not nearly as stable or versatile.


And finally, let me say: Florian, you and your wonderful app are appreciated!

I also was surprised that the default search for cover art has changed without showing a sensible default.
Luckily I found this thread and the hint to set the directory to %_folderpath%.
I wish there would be some examples in the options field to give a clue without the need to study extensively in the help pages.