Cover art in Windows7

Dear readers,

I have my whole CD collection converted to my PC. Also the covers.
I'm using MP3TAG v2.45a (great program!!) for the file information and covers.

I think the program is working fine but here is a problem:
The cover art is not showing in explorer. The MP3 file icon stays.
All the other thumbnails of my media files (avi, mpg, jpg etc...) are showing fine.

I see the cover in Winamp and in Mediaplayer. Also the size of the MP3 is bigger.

My question is: How do I make the cover art shown in explorer, and see the CD cover instead of the MP3 icon?

I'm having a new PC with Windows7 (legal).
With Vista it was working great but in Windows 7 not.

Thanks for reading! And I'm hoping for advise.

Hi Michael,

it works here (Windows 7 too) when using the 'Large Icons' or 'Medium Icons' options.

Kind regards,

Thank you for your reaction!

Hmm, that's to bad.. Here it's not working..
Also the tags are not displayed in the "file info" in explorer.
So I'll guess there's something wrong with my system.


Can you tell me what is listed in the Tags column in Mp3tag's file list for those files?

Kind regards,

occasionally windows seems to have a will of its own and treats directories not in the desired way.
so if you open the properties dialog for the folder you may check what windows thinks what kind of folder it found.
e.g. windows may think your music library is just a plain old data folder. Select in the tab folder "Modify" (German: "Anpassen" ) as template (Vorlage) "Music" (deutsch: Musik (am besten für Musikdateien).
Perhaps then all looks nicer for you.
Also, the type of columns that windows displays will change from size and filetype to artist and title.
It may be that a desktop.ini file got deleted.

Thanks again for the reply!
In the 'tag' column: "ID3v1 ID3v2.3".
Everything is listed as normal.

Thank you for the reaction!
I'm from the Netherlands :slight_smile:. If I look at the folder properties, it saids "music".
'desktop.ini' is there made on date 02-12-2009.

In the desktop.ini ile:


Thanks Florian and ohrenkino for reading and advising! I'll think I'll let it pass. It is annoying but oke haha!


Hi Michael2002 don't despair yet!
A Microsoft Forum gives the advice to set the folder options in Explorer: Open Explorer, Select function Extras: Folder options
Open tab folder "View"
Scroll down the list of options until you reach "Always display symbols instead of miniatures" (or something similar - this is my crud attempt to translate teh German GUI into something English-like). In my list this option is the 7th checkbox from the top).

If the box is ticked this would explain why you do not see any cover art.
Untick the box, press apply and the window in the background should show the cover art).
It only works in Modes that show miniatures, though, so not in Lists or Details.

Thanks again.. I'll tried all possible options. But still nothing.
Also at what you told, nothing...

I let it go. It's annoying, but no big deal.

Hello Michael,

I found it very annoying too, and I was looking for an answer for many weeks, after trying many things I found a ""solution"" [yes, with DOUBLE quotes]

When I'm getting tags from (for example), and then I go to the "Adjust Tag Information" window, there is a small button in the corner that it says "Utils" (below, on the left), you just have to click it and select "Save Image To Disc", this will create a filename called "folder.jpg" which is loaded not only by the explorer, but the Windows Media Player.

I know this is not a "great" solution, but it works in my Windows 7

Good that that works for you. Please note that there is an action in MP3tag that exports exactly this folder.jpg from all the selected mp3s.
(I doubt that it would be that easy as the original question stated that the same directories worked fine in XP. And nothing has changed in respect to folder.jpg and albumartsmall.jpg.

If you are more interested in handling specific WMP peculiarities search for ALBUMARTFIXER, a freeware program that parses through your WMP library and files to check them and their well-mannered behaviour in WMP.

Hi everyone. I'm an avid user of mp3tag, it is really great, and I'm posting because I reached the forum looking for a solution to the very same problem discussed here. After reading the thread, I assume what happened was due to uninstalling Winamp with Revo uninstaller. The scanning for registry keys must have deleted more than needed, probably erasing MP3 file info.

Solution: I tried every single thing, until i tried System Restore. A went back to a previous restore point to uninstalling Winamp and the thumbnails are back. Hope it helps.

Happened to me as well. Then I discovered, that there were more than one cover saved in the mp3. One was blank, the other was the correct one. :music:

What about if you forgot to do a restore point before installing Winamp? :angry:
I thought Windows 7 did a restore point before installing programs, just like XP (at least XP did for me), but it doesn't. Now all cover arts from every single MP3 are gone. (M4A cover arts are still there though)

I've tried using CCleaner, cleaning the thumbs cache, re-tagging, but nothing seems to work. :frowning:

Oh, I'm sorry for any mistake I may have made, English is not my mother tongue.

Ps: I thought of starting a new thread, but since the original poster's problem is the same as mine, perhaps I'd post my problem here instead.

ETA: forgot to say, the album arts do show up on MP3Tag and on Foobar2000. Maybe Winamp could've messed up them, but it seems it hasn't.


It's not that the covers are gone. It's that somehow, Winamp uninstallion process has messed "mp3 file info" in Windows Explorer, so Explorer doesn't "know" how to show as an icon the cover inside the mp3 file.

I guess there must be a way like exporting Windows Registry information of mp3 files from a "healthy" Windows 7 to your PC so cover can be seen again...

Thank you for your reply!

Damn Winamp. lol If at least I Knew what's borked I could ask a friend, but since I don't it's almost impossible to fix.

Anyway, thanks!

ETA: Yayyyyyy I did it!!! This time I went to Google and put something like 'mp3 registry fix cover art' and I found this site:

All I did was use the 'code' from jblade posting, and my covers art are back. xD

For anyone else who is having the same problem, I've uploaded the .reg file: Just download, double click, Yes, and enjoy. :smiley:

Use CCleaner or some alike tool to clean your thumbnails cache btw.