Creative Zen 30GB


#1

i have a Creative Zen 30GB. i recently began using Mp3tag to tag my mp3's. i prefer TagScanner, but the version i used last kept crashing. i decided to try Mp3tag instead. i like the various tag search options as compared to TagScanner which only offers the freeDB option. here is the problem:

every album that i have tagged with Mp3tag shows all the tag info in my media player except the album year.

first i thought i just messed up and saved the files w/o the year info. i checked the tags and the year was there. at that point i tried to alter the tag type used as far as the ID3v2 format. this did not make any difference. it seems that no matter what i change, when i use Mp3tag to tag my albums, the year is not displayed for any of the tracks when looking at them in the media player.

i tried a search on this issue in the forum and got nothing. any help or suggestions would be highly appreciated.

TIA


#2

hey wow, nobody responded yet. interested or not, i did some checking and it appears that this problem may not be associated with either of the tag editors. it may actually be an issue with the Zen Vision (ZV30GB). last night i downloaded everything that was on the ZV30GB to my hard drive and checked/reformatted all of the tags on all of the albums. when i put the albums back on the ZV30GB, none of them showed the year. it appears that it is the device and not the software. since this was not happening until recently, i would tend to blame the firmware update(s) from Creative.

obviously this is not the forum for issues with the ZV30GB, but if anyone has any idea why this would occur, how to fix it, or where there is a link about this issue, i greatly appreciate it...

TIA


#3

okay, my bad. it was not a problem with any particular software package used to tag the files. turns out the problem was that i was transferring the media to the ZV30GB using the storage device window as opposed to using the Creative media software interface. the tags are not supposed to transfer well at all when information is copied ot the media player as a storage device. oddly, the only tag field that indicated any actual problem was the year field. long story short, i fixed the issue by properly copying files to the media player.