Customize Column abnormalities


#1

I'm a newbie with the utility, running v2.40. It looks like a great product!
I'm seeing one issue which I've not been able to resolve. I'm not sure if it is a product bug, or a user issue.
My platform is Win32 XP SP2. All my target files are .mp3 with tag format ID3V2.3 (ID3V1 ID3V2.3) as displayed by MP3tag.

When I choose the "Customize Column" option, the columns FILENAME and GENRE fields are not displayed columns. The field checkboxes are available, and checked, but if I select everything, these three columns will not display. If I choose ONLY these two columns, then my display area is blank. I have also tried a mix and match of other columns, but no matter what, I cannot seem to get these two columns to display, while all others WILL display. And yes, I have verified that the checkboxes next to those fields are checked.

Note: the FILENAME and GENRE info is visible if I right-click on a file and see file properties, and GENRE is there to be displayed/edited in the Tag Panel. But, neither filename nor genre will display in the "main" viewing area. All other columns will display.

Is it me, or a possible bug? Anyone else seeing this? Any suggestions welcome.


"Album Column"
#2

Just a follow-up with a work-around.

I created two new columns, genre2 and filename2. Each column has the exact same Value, Field, and Sort-By values as the originals.

The new columns will display.

The original genre and filename columns still will not display. But, this work-around is sufficient.


#3

You can open the columns.ini file which is located in %appdata%\Mp3tag\data with a text editor and check the values. Maybe the width is set to zero so you can't see the column.


#4

Thanks. I did look, but I don't seem to have a columns.ini file under v2.40 (my only/first installed version, so maybe the ini file is legacy from a prior version?). I searched the application directory tree and then the boot drive. ironically, i do have a genres.ini file. which has only a single line "Flop=".


#5

No you went to the wrong folder. Pay attention to %appdata%
freedb and Web Sources


#6

Thanks. I had neglected to search hidden files, so I DID miss the columns.ini file in the %appdata% directory tree.

That was it. Width WAS set to zero for those two columns. I have now set them each to the width of my two dummy fields (genre2 and filename2) and restarted mp3tag. The original and my new columns display now.

I appreciate the suggestion--and the clarification.