Datendurchsatz IBM Thinkpad T4x bei 2 bis 3MB/s (XP SP2)


#1

Mein Hauptsystem ist so ein gutes Jahr alt, ein Laptop der T4x Serie, der im Sommer eine neue Toshiba 120 GB Platte bekommen hat.

Nun habe ich ein schleichend einsetzendes Problem, was ich zunächst auf itunes 7 geschoben hatte:

Mein System ist aufgrund des Datensurchsatzes zwischen 1,5 bis 3 MB/sec sau langsam geworden. Es ist ein akutelles XP SP2 mit sämtlichen Updates in deutsch, die Installation ist so knappe 6 Monate alt und recht aufwändig, also keine Lust, alles neu zu installieren.

Woher kommt der niedrige Datendurchsatz, nachdem mir bei einer alten 48 GB 2,5 IBM USB2 Festplatte der Speed aufgefallen war. Daraufhin habe ich mal Performance test mit HDTune gemacht und die USB Platte läuft mit 25 bis 30 MB/s, nur meine interne Hauptplatte, das Herz sozusagen, das schafft nur ein Zehntel und das kann nicht am Virenscanner oder AdWatch oder Virus liegen.
Mittlerweile sind schon die Virenscanner rausgeflogen, aber das hat nur wenig gebracht (nachkommastelle).

Wo kann man schnell was finden bzw. wer weiß was, da0ß ich dieses Problem ohne Neuinstallation los werde?

Ich habe schon mit Registry System Wizard alles rückgängig gemacht, was es dort an Optimierungen gab.

Ich hoffe, es fällt Euch was ein.

Tausend DANK
Wolfgang


#2

B)-->

QUOTE(Wolfgang B @ Nov 28 2006, 19:28) <{POST_SNAPBACK}>
Mein System ist aufgrund des Datensurchsatzes zwischen 1,5 bis 3 MB/sec sau langsam geworden. [/quote]
Schaue im Hardware-Manager nach, ob bei deiner Festplatte/Festplattencontroller DMA aktiviert ist.
Die neuesten Treiber fürs Chipsatz zu installieren schadet auch nicht.

Gruß
nickless


#3

#4

Lösung

Nachdem das System so ätzend lahm war, habe ich nicht aufgegeben und nun weiter nach PIO gesucht... und hier ist die Lösung, nachdem ich feststellen konnte, daß am sekundären IDE das schnelle DVD Laufwerk mit DMA2 hing.

Mit ein wenig Suche im Gerätemanager konnte ich dann erkennen, daß am primären IDE definitiv die Bootplatte von Toshiba hängt (Ultra DMA Trieiber ist eine Extra Kiste wohl für die Dockingstation). Dort war auch der Eintrag "nimm DMA wenn möglich", genommen wurde aber nur PIO. Nun muß man wissen, was PIO ist ... eine saulahme Krücke, kann ich nur sagen und die Arbeitsweise bzw. die Aktivierung und Folgen sind gravierend.

Wenn XP mehrfach einen Fehler mit einem DMA Gerät feststellt (z.B. bei DVD Laufwerk eine schlecht lesbare DVD) dann wird automatisch die Option " DMA fällt zurück auf PIO" genutzt und die DMA Modi von Modus 5 langsam zurückgestuft bis sie über DMA-2 bei PIO anlangen. PIO bedeutet 1 bis 3 MB/s .... wobei die DMA 5 30MB bedeuten.

Man hätte das am USB Laufwerk erkennen können, dass es was mit dem IDE zu tun hat, besser mit dem primären, weil Bootlaufwerk, denn dort war der Durchsatz hoch.

Die Option ließ sich wohl bisher/lange Zeit nicht reaktivieren, nur mit Deinstallation des Treibers und Neuinstallation, was man beim primären Bootlaufwerk nicht so gern macht.

Hier ist nun eine gute Lösung via Registry , wobei der Teil ab "Prüfen Sie den Übertragungsport des IDE Port" relevant ist.

Das Ganze ist eine Schweinekiste und ich habe nirgendwo einen Hinweis gefunden, sprich 4 bis 5 Monate lahme Krücke.... und nun ist itunes wieder normal und brauchbar... ahh, ja.