Default folder location with adding cover art

First of all, thanks for making and offering this great software free of charge!

Now to my question. I've been using MP3tag for quite a while now and noticed a sligth discrepancy in the way MP3tag works when adding album art. Most of the time when I click "add cover..." the file browser window opens in the folder where the mp3 files being tagged are, but occasionally it's the last folder viewed. I haven't figured out any pattern to this and presume this to be some sort of a glitch in the progam?

As I happen to keep my album art files in a different place than my music, that occasionally occurring "last folder viewed" phenonemon is in fact very convenient.

I looked through the options and the only thing about album art is the default file name for album art under "tag sources."

Could you consider adding the option of choosing between the currently default mp3 file location folder and the last viewed/used folder?


Do you have the latest version? There's a new cover location option at Options > Directories

It doesn't have a last used folder option, but you can enter a default location.

I'm using 2.51 at the moment. The possibility of adding a default folder for album art will certainly be useful. I'll have to get the newest version. Thanks!

Funny, I was thinking how being able to drag & drop the album art would make all the album art file browsing unnecessary. Tried it in the program before making a suggestion, and turns out it's already in there! :rolleyes:

I'm using 2.55a and it is opening the directory I scanned and not the directory where the file is. That's a real pain.

So.. I have

-MP3s/Genre/Artist/Album 1
-MP3s/Genre/Artist/Album 2
-MP3s/Genre/Artist/Album 3

In Album 1,2,3 I have a folder.jpg file

If 'directory' is set to MP3s/Genre/Artist, I see all my files, but when I add cover, it opens at Artist Level, to allow me to choose Album 1, 2 or 3 folders. If I can at Genre level, I'm presented with hundreds of Artists.

This behaviour is completely wrong and needs to be fixed if possible.

Set the directory to %_folderpath%