Delete mp3 and cdg at same time

I like the new delete feature where it will delete the file, however, is there a way to delete the .cdg file at the same time? It deletes the mp3 file but leaves the cdg file in the folder. If not, can this feature be added?

Thanks.

To delete both cdg and mp3, you will have to create a tool and a bat file. Here are the steps:

First create the bat file.

  1. Start notepad and save the file as "DeleteCdgMp3.bat"
  2. Put the following two line of codes in there
del %1
del %2</blockquote>

The %1 is the full path and file name with extension of the first parameter you pass to it. We will assign it as the cdg file.
Likewise, the %2 is the second parameter. The word "del" is the delete.
Now save the file somewhere.

Second, create a tool in Mp3tag to run the bat file and define the parameters.

  1. Create a new tool, Ctrl+O. Call it "DeleteCdgMp3" with the following:

    Path: Browse to where you put the bat file, example "C:\DeleteCdgMp3.bat"
    Parameter:

"%_folderpath%%_filename%.cdg" "%_folderpath%%_filename%.mp3"
2. Check whether you want to do this for all files you highlighted or just the single one with your mouse cursor over it.

You are done, now select your file(s) and run the tool. Noted that doing it this way WILL NOT CLEAR the file name from the Mp3tag window, you will have to refresh your Mp3tag windows to see it disappear.

A second method is to only delete the cdg file and leave the mp3 file for your Mp3tag software to delete and clear at the same time. To do this, don't pass the mp3 parameter to the bat file or edit the bat file and del only the %1 (first parameter).

I hope this help. Have fun karaoke 'ing.

P.S. Thank you to the creator of Mp3tag and whoever came up with the "rename cdg along with mp3" automatically in the "Tag- Filename"; saves me a ton of time.

Edit: your filename and path cannot contain the symbol "&" in there, replace and rename your file to get rid of the "&" before running this tool. I think this goes true with other command line symbol such as %^$ and etc.

Yes, when working with the DOS command line you have to escape special characters.
Use the function $replace() this way ...

$replace(,'^','^^','&','^&','|','^|','<','^<','>','^>','(','^(',')','^)','"','^"','+','^+','\','^\')

... or this should work too ...

$regexp(,'[\^\&\|\<\>\(\)\"\+\\\\]','^$0')

DD.20120211.1128.CET
Edit.DD.20120216.0702.CET

Bumping this since it would be nice if it was a built-in feature for MP3TAG. CDG files are always managed in pairs with their matching (by name) .mp3 files. Since MP3TAG already treats CDG as a unique case (and it is), it really would be nice to have the Delete and Move functions work on both at the same time.

For now I'm using the workaround suggested above but not refreshing the file list is a pain.

(And yes, MP3TAG is an awesome program!)