Disable auto-fill of tag info?


#1

Let me apologize first if this has been answered before, I done a search without any luck.

I would like to have tags only in certain fields (Title, Artist, Album, Cover Art)

  • Title being the track title
  • Artist being the track artist
  • Album also containing the Artist (so that if I go to the artist it will show all tracks by the artist in one list instead of having to switch between albums)
  • Album Art (All Tracks from the artist have the same Album Cover associated with them)

I play my music though Windows Media Player 12 or Media Center & use iTunes to manage music on my iPad (but never play the music though iTunes). Before I started to edit the tags I went into each program & disabled the setting to Download Tag Data from the internet.

Then started to edit the tags. I got all the Tags that I wanted filled with the correct Tag Info & removed all other Tag Info that I am not concerned with. Rebuilt the libraries, removed all music from my iPad then re-added with the Tag info as I wanted it. It was perfect! In both Media Players on the PC & the iPad all the Tag Info & organization was just the way I wanted it.

After a few days I noticed that other tag info is getting filled in (Genre, Track Number, Year, Composer, etc) which I would prefer not to have.

I have fought with this for quite some time now but just go back & take out the Tag Info that I dont want. Starting to think that I'm fighting a losing battle here.

Is there anyway to stop this from happening?

Thanks in advance for any & all help with this!


#2

You could check your firewall and disable the internet access there as well for all those programs you use as player.
I suspect that WMP still is nosy even if you have told it not to snoop around.


#3

I was thinking the same thing but I believe that would create another problem (but I could be wrong), I use the Media Stream feature of WMP 12 so that I can access my Music, Movies & Photos while at work, family's house, etc without having to carry a external HD: for easier management & a well synced library (since all the PCs that I access would be using the same library stored on my home PC)

I'll give it a try to see if it helps but the convenience of being able to access my home media library while away is much more valuable to me. It's pretty simple to remove the Tag Data that I'm not interested in since they can be removed in Batch, just kind of annoying to redo them all the time.

Thanks for your input & if any other ideas come about please feel free to share!


#4

Once you have set the tag data in your file, you may set the file attribute to "read only".
This can prevent the file from being overwritten.
If this does not help, you can try harder and set the file attribute to "system".

DD.20111209.1756.CET


#5

I didn't even think about that one! Sounds & seems like it will work. I copied a few of my mp3s to a USB drive to bring to work & do some testing to see if I can find any answers. Changed the file attribute on those & it seemed to do it. I'll check with the rest when back at home.

Many thanks to both replies & I'll keep updated on if the fix worked or not.


#6

Picking up on DetlevD's idea - I am not quite sure how firm you are with the good ole DOS commands.
I recommend the attrib command as this works on a whole tree of subdirecories and can be executed in a batch routine.
e.g. starting in the top most folder of your music library and executing
attrib -r *.mp3 /s
will remove the write protection from all mp3s.
attrib +r *.mp3 /s
will set it.
So if you create two simple text files, one for adding and one for removing the write protection, you can easily set the right attribute prior to editing (and afterwards).

Sorry, if I have bored you.


#7

The Read Only attrib seems to be working as a great work around. I have not noticed any tags being filled in that I'm not concerned with. A batch file would eliminate a few clicks when I need to make changes, which is something that I will keep in mind as that Library grows. There also seems to be some tag info that does not show in Mp3Tag even with reading of APE enabled. I can see the tag if I right-click & go to Prop but it wont let me remove. It's not too many so I'll just deal with those for now.

Thanks again for the assistance, Very Much Appreciated!


#8

Be aware of, when Mp3tag options for Mpeg reading is enabled for tag-type APE, this will hide all other tag-type's data from being shown.
Mp3tag gives the tag-type APE the highest priority (APE>ID3v2>ID3v1).
In order to see other tag-type's data you have to disable the reading of the tag-type APE.

Related to the currently read tag-type, you can see the content of all tag-fields within the dialog "Extended tags..."

DD.20111213.0850.CET