Disable auto-save on renaming and double-click default


#1

Hello,

When I rename a file in mp3Tag, saving the file occours immediately and automatically.
Is there a way to disable this auto-save and do it only manually (with File->Save command)?

Another question: sometimes I would edit the fields directly, but accidentally I click too fast, and this play the file (WMP is launched).

Can I disable or change this feature?

Tnx in advance.


#2

May I ask why? To tell the truth, I've never noticed this behavior.

What I do when I edit files is that I first do any necessary manual edits in the Tag Panel - usually shared fields like ALBUM, ALBUMARTIST and GENRE, then do a Save. Then I execute from 8 to 12 different action groups. Their order is very important, so close attention is paid to the order that they appear in the Action Groups dialog. The very last of these action groups is one that renames the file.

Yes. Go to Tools > Options (or use Ctrl-O) > Tools, and set the Default Tool double click program to 'No action'.


#3

I usually edit a list of mp3 directly on the main window, so the edits apply immediately.

I do so because much faster (for each change, I press Enter, and the selection moves quickly to the next file).

I know, maybe I'm used badly, the Tag Panel is safer, but I was wondering if you could avoid that behaviour.

For the second my question, ok, I didn't noticed the option.

Thanks for your reply, JJ.


#4

So you're manually editing the filename in the columns ('main window')? That's a little unusual, but I suppose it's not unheard of. Most people have one (or a few) set filenaming conventions that they use, and they create one or more action groups to automate this.

Yes, using the columns in this way can be very fast when editing tagging fields for individual files, although I generally only use it for editing track titles and for editing artist names on compilation albums.

But you still haven't explained why you'd prefer that changes not be saved immediately. From what you've just said, it's very fast, so apparently speed isn't the issue.


#5

Try disabling this option.

Although I never have it ticked. I've tried it and changed a tag. Closed mp3tag without saving and opened the same file again but the changes I made have taken effect. Other than this option I can so no other way around your problem.



#6

Oh, sorry JJ.
I thought that in this manner is more safer.
I know, I can use the "undo" command, but if program crash, for example, the renamed files could not be brought to the initial name.
I am always very cautious with the renaming of files, so it seemed a safer and simpler approach: first I do the changes and then when I'm ready, I save the job.

But I think it is a feature of which apparently I only need, so no problem, I'll use the "Tag panel". :music:

Please note that I'm using Mp3Tag for a few days, so I have to study more and more... :book:

@ stevehero
I tried this option, but it doesn't solve my problem (maybe 'problem' is a little excessive :stuck_out_tongue: ).