Drag and Drop not working

Hi all,

Drag and drop is not anymore working. I've been using MP3Tag for years now, and I really love this program.

I'm on Windows 10 64bits and it was working fine until now.

I read some topics on the forum and tried several things:

  • Run as admin
  • Uninstall / Reinstall
  • Delete all registry entries containing "MP3Tag"
  • Changing users permission on exe, install dir, settings dir

But I still can't drag and drop any file or directory.

Any idea?

Thanks.

Is Drag&Drop still working with Windows or other software?
Is only Mp3Tag affected?

Not only the installation directories - this should be ok as soon as you install a new version.
The audio files also have to be accessible by the current user.
In the Windows Explorer, you can add a column for the owner. If that is some numbers-and-letters-gibberish, you should either add "Everyone" or "Guest" to the users that are allowed to modify the files or change the owner to the current user.

What do you mean by

?
It changed behaviour in mid-operation or after you switched to W10?

I tried with other softwares, even with one I developped, no problem!

Yes I confirmed that it changed in mid-operation. I'm sure it was working 15 days ago (the 25 of October), and I was already on W10 (I did a clean install of W10 several months ago). Since, I didn't change any kind of administrative parameters. Can this be due to a Windows update?

Please see also the other point:
If you did a clean install, you probably modified the user-ids. So please make sure that the current user has sufficient access rights to modify the audio files. Being administrator is not enough.
The best thing would be to change ownership so that the current user-id is also the owner.

I finally managed to make it work!!! Indeed, it was a policy problem , but not a file or folder owner problem. Just for your information; I have a single personal account with admin rights. All the files and folders I create are either owned by my personnal account or owned by the administrators account (according to their location). I revert back all the changes I did in ownerships.

A brief history:

When I installed Mp3Tag just after a fresh installation of W10, Mp3Tag couldn't save its settings unless I launch it as admin. I then changed the exe properties so that it is automatically launched as admin.

Now, for some reasons I don't know (but I suspect a W10 update) Mp3Tag needs to be launched normally (not as admin) to fix the drag and drop problem. More surprising is that settings are successfully saved now...

Many thanks for your support!