Drag/Drop files into Mp3tag window

Just started using Vista Home Premium and I've got Mp3tag v.2.39 working fine now except for one problem:

In order to have permissions to actually tag a file on an external drive (connected by USB) I had to choose to "Run this program as an Administrator" in the program's properties (despite the fact that I'm logged into the Administrator account for my home PC), but in doing so I've now dis-abled the ability to just drag and drop files into the program from their directory window open on the desktop -- and this is affecting external and internal drives. I now have to use the "Change directory" function and drill down to my files every time instead of being able to just drag/drop folders/files into the program directly.

Certainly not the end of the world, but it was much more slick when I was able to just drag the folders/files into the program. In XP this all worked fine, but with Vista once I enabled the "Run this program as an Administator" option in the properties I lost the ability to drag/drop.

Any ideas on how to fix this?

I'm no wiz on the PC, and I'm not an absolute moron either, but I'm sure there's something I could just be missing here???
thanks in advance!
dug

Drag'n'drop doesn't work between administrator and regular processes, such as Explorer on Windows Vista.

Kind regards,
Florian

If what the guy says here about vista is true, you could try running explorer.exe as administrator, then also running mp3tag as administrator. Use this 'admin explorer' to drag and drop.

Or you could pick the far more obvious choice of not using Vista? lol...

btw I think you'd have to find explorer.exe first. Probably C:\WINDOWS

Ha! I wish I hadn't rushed into the purchase of my new PC, but I can't go back now and it won't run XP because there's no drivers available...but that's another story...

I tried altering the explorer.exe to run under adminstrator permissions but it won't allow me to do it (at least not easily -- the properties don't allow this as a choosable option since it's greyed-out). Not sure if that would be all that great as it would mean everytime I opened a directory I'd be asked for the administrator password, if my understanding of the OS is correct...and my wife and daughter use the machine as well....thanks for the idea though -- I thought it might be a good thing....even just being able to do that on the exploring of my music directories, but it doesn't work like that...

Florian, if I could bother you a little further: Do you now how I can get the program to be able to use the options under the Convert menu, for instance renaming the files from Tag info, without having to enable "Run As An Adminstrator" on the program? If I do not enable the administrator permissions I get this error when trying to save tag info to a filename:

File "C:\XXXX.mp3"
cannot be renamed to "C:\AAAA.mp3"

Access is denied

...I've been under the assumption I have to enable "Run As An Adminstrator" in order for that sort of Action to work.

Thanks for letting me know I wasn't just crazy though for not being to drag/drop...HA!
dug

Hello you all,

Although I am new in this forum, I have been using mp3Tag editor for quite sometime now with excellent results (I tried close to 10 different programs before I decided to permanently use this one).
Today, a message came up saying that I had to upgrade mp3tag editor since a newer version was available, so I did, I think I jumped from v2.38 to v2.40 and to my surprise I couldn't drag whole folders to the main mp3tag window and simply drop them anymore, which came as a surprise since I have always been using windows vista and never had a problem with it before. So I tried doing what seemed the only logical thing to do at the moment, I uninstalled mp3tag v2.40 and re installed v2.38, but I am still having the same problem. Is there anything that can be done????
It's not such a great deal having to go through the add menu, but in the long run it ends being a royal pain in the butt when you manage a large ammount of data.
Thanks in advance for all the help you guys can give me regarding this matter...

-Chris

Well, I neglected to post back how I fixed the drag/drop problem when I got it working, although if memory serves me right it was merely a fluke.

I just re-installed Vista again to fix some other trouble so had to set up mp3tag again. I too was just having the drag/drop problem again and couldn't remember what I'd done before to get it working.

BUT, here's what I just did that now has it working for me:

  • install the program while in the standard account you'll use it in and allow it be held in the Program Files directory (which is actually owned by the administrator)
  • open the program and try drag/drop-- it will NOT work
  • right click and choose Properties in the menu
  • go to Combatibility tab and click 'Show settings for all users'
  • enter Adminstrator password when prompted
  • under 'Privilege Level' check the box for 'Run this program as an administrator' and click 'Apply'
  • close the Properties window, open the program and try it -- it will NOT work.

NOW, and this is the funny part, undo what you have just done -- follow the steps above, but de-select 'Run this program as an administrator' under 'Show setting for all users' and the click 'Apply' again. Open the program and the drag/drop now works...why you ask? I have no idea, and I don't know if this will work for anyone else, but it worked for me.

Hi guys, just wanted to thank you and confirm that this workaround, although strange, has worked for Win 7 as well. :laughing:

hi folks,

I actually installed 2.46a and then 2.43 ... and had the same problem ... here is what worked 4 me on 2.43 (i don't feel like uninstalling and installing 2.46a) ...

  • Righr click MP3Tag icon > Properties > check use in XP Compatability Mode ... and you are done! Did Not need to run it as Admin.

Thanks,

G! :slight_smile: