Duplicate #'s in 1 folder can I fix

I have duplicates of every single song ie 2 #1's etc. I have spent a day trying to find a program to renumber in straight order from 1-40, but no luck. I joined here & don't want to write a program or scripts. I played with the autonumbering option which should fix it but nope.

The Auto-numbering Wizard has no problem with assigning consecutive track numbers from 1 to 40 to 40 selected tracks.
What does duplicates have to do with your question?
Please give a more detailed example of what you are trying to do.

Here is what it looks like now. NO not duplicates, like I said in the post it the numbers that are duplicates NOT the songs.

Those are the file names. If you want them to have new "numbers" you will need to rename the files. If you use the track number wizard mentioned above, it will change the field %track%. And if I assume the field %title% is also already completed, you can then you an Action Format Value like this;
Field: _FILENAME
Format string: %track%. %title%

This will rename all of these files with the new, unique number, followed by a dot, space, and title.

I just tried this & checked and unchecked all the options within Auto renumbering tool. Where it I find Auction Format Value?

Actions are not part of the wizard. Look at the tool bar;
Actions>Actions (Quick)>Format Value

1st if all thanks. While I am 72 yo I am pretty good with computers. I tried cut & pasting your suggestions Field: _FILENAME
Format string: %track%. %title%
And this is what I got - same issue.


Any idea or just live with it?? Again thx for trying to help me.

You need to make sure the metadata information is updated before you can run this action. The metadata is separate from the file names, they can be completely different. From A to Z try this work flow.

  1. Load the files you want to change into mp3tag.
  2. Make sure they are in the order you want in the list you see (use the Alt+ up/down arrows or Alt+mouse to drag them if necessary).
  3. Highlight all tracks (easiest way is to use Atl-A) or use the Select All icon in the tool bar.
  4. From the menu bar, go to Convert>Auto-numbering Wizard and choose the options you want. It should default to show beginning at tracknumber 1 and ending at the total count of files you have highlighted, I would leave it that way for this scenario. Then press OK.
  5. While all files are still selected, and again from the menu bar, go to Actions>Actions (Quick) and choose Format Value from the list.
  6. Set these criteria and press OK;
    Field: _FILENAME
    Format string: %track%. %title%
  7. Verify that your file names have now all been updated to show unique numbers to start.

If you could include the columns for Track and Title along with the filename after you have done this, it can be verified here.

Again, thanks for hanging in there. I had already done step by step what you listed. But just to be sure I created a duplicate folder to play with. It after step 6 a box pops up of course to show the progress of the procedure. Nothing happened. So, I'm back after looking at Windows Explorer which has the columns you asked for. I doubt it will help but ok.

I can see the track numbers in the second column are in order. So that was updated. And the title information exists as well. So if you run the format Value Action properly this should be changing your file names.

Grab a screen shot from mp3tag with at least these columns showing, a few more if they apply; filename, title, track, album

Something like this;

Using the exact same 7 steps I posted above, this is what the results were with this selection;

Note I intentionally deleted track 24 from this folder before I did anything. The first screenshot jumps from track 23 to track 25. So when I ran the numbering wizard it updated the list to run 1-29 in order. Then when I did the Action step to format _FILENAME it now lists them 1-29 and added the period after the number. So this works 100% to what you were looking to do.

I decided to let your reply simmer overnight to see if it was clearer today. It's not. #1 Congrats on your taste in music. Being 71, I am really old school. It's called Classic Rock for a reason - lol. Anyway the problems I see with your list is it never had two #1 tracks etc to begin with. I also didn't notice the view screenshot ie on the left you got a box with all the options - choices. I played around with MP3 Tag & never could find that screen or option. I could get close to this, but not like yours. What I mean is way down at the bottom left your shot has a lot more options ( Track, Total Tracks). I doubt even if I could pull this up on mine it will fix my issue. So sorry - I may give up. But here goes.
1-Could the issue be that on my folder it has a bunch of different Albums under Albums?
2- If you notice on mine because of this issue it only goes to 20 tracks when if correct it would go to 31 tracks.
I also tried to do a screenshot of what I see with my MP3Tag with this album loaded.


Again much respect & thanks. I am a Mod for Nextdoor website in my area & while it's a bit thankless, I care to help. Peace-Out.

This would only be a problem if you have them in different folders and ticked the option "Reset counter for each folder" in the track numbering assistant.
What happened when you applied step

i would expect that the number in the column "Track" changes.

Maybe I am just dumb or maybe I should just give up. After reading your reply, I looked again ( really close). The issue that I 1st brought up is under the Filename Column is the issue. There it duplicates every track ie two #1 etc. Under Track column it's correct ( 1-31)
MP3Tag box with options
. Now in iTunes everything looks fine & it doesn't even show the track numbers. It only shows the 2 #1 2 #2'S etc in Windows Explorer. Being a bit OCD I was trying to deep clean my MP3 folders. I tried Music Picard, Tag programs, renaming programs nothing did it. Lastly I came across this option under Quick Options Replace with Regular Expression. You can see I got the 1st column ( Filename) but the next 1 or 2 have no clue what to input. Under Filename it gave me the choices - under Regular Expression it's blank so no clue what to input.

Please note that the FILENAME is no embedded metadata. It is something the OS needs to manage files. So, for a decent player, the filename does not matter, only the embedded metadata (tags) does.

Anyway: to get the data from TRACK and TITLE into your filename, use
Converter>Tag-Filename
Format string: $num(%track%,2). %title%
The preview should show whether this turns out right.

The action that you chose (Replace with regular expression) will not really help as it looks for patterns in a string and modifies that.

Two problems that haven’t followed my suggestions.

  1. The auto numbering wizard - every track shows 1/31 which means you have changed a setting there and have it starting over after every track. This step needs to be fixed first. Once done correctly you will see tracks numbered from 1/31 up to 31/31.
  2. Once you verify the above and tracks are numbered correctly. You need to go to the Quick Action menu and select the function FORMAT VALUE (not the replace with regular expression you found). Then use the criteria I provided you earlier to update those file names. OR you can use the converter that @ohrenkino suggested as well as an alternative.

No it didn't fix anything in fact made it a bit worse. I changed it & now every track number is #1 & the filename changed to Artist Album Name # which all changed to #1.

Could you please show us with screendumps what you really do?
It looks to me that you do not apply the functions that have been suggested by @MotleyG and me.
I still think that you did not set the options as suggested

and here:

Still playing around & so sorry to Motely & Oh. #1 did fix the track numbers ( ie 1-31) so yay! #2 didn't do anything I tried looking for the converter & clicked on @ohrenkin but couldn't find converter. So sorry for the pain & work you guys have done, but I am pretty stubborn so will keep playing with it. To me the problem is the Filename. If I could strip the double numbers or ALL numbers out of the filename that would fix it. Here is the newest try with the correct # of track ( 1-31) but still the double filename numbers.

"Converter" is a menu title.
Alternatively, press Alt-1
... and what about a look at the documentation?