Einzelne Tags werden gelöscht


#1

Hallo zusammen,

das Programm benutze ich seit Jahren und möchte mich erst einmal dafür bedanken!

Ich habe einen Fehler, der regelmäßig und häufig (1-2/10x speichern) auftritt. Meistens erst nachdem ich 5-10 Minuten mit dem Programm gearbeitet habe.

  • Ich markiere mehrere Dateien und ändere ein oder mehrere Felder.
  • Wenn ich die Änderungen speichere, dann verschwinden fast alle Tag-Informationen aus einigen Dateien. Manchmal nur von einem Lied, manchmal auch mehrere willkürlich ausgesuchte. Auf dem Bild im Anhang sind die Informationen aus aufeinander folgende Titel verschwunden, dass ist eher selten.
  • Wenn ich nun die betreffenden Titel anklicke oder die Ansicht aktualisiere sind die Informationen wieder da und wurden richtig gespeichert, selten bleiben sie verschwunden.
  • Ignoriere ich den Fehler und arbeite weiter, so sind die Informationen meistens verschwunden.

Ich meine das der Fehler nur auftritt wenn ich die Dateien zum ersten Mal ändere, wobei ich sie auf jeden Fall schon einmal vor längerer Zeit mit MP3Tag bearbeitet habe.

Win7 64

Gruß,
Guido

Mp3tagError.log (1.82 KB)


#2

leider war kein Bild angehängt...
jedenfalls: kannst dumal checken, ob die seltsamen dateien APE tags enthalten - die verursachen manchmal so seltsame darstellungen. Wenn APE-Tags da sind, solltest du sie löschen.

Auch könntest du in Extras> Optionen checken, ob du APE schreibst. das solltest du nicht.


#3

Hallo,

Danke für die Hilfe!

APE schreiben war angeklickt.
Nun habe ich bei Lesen und Entfernen alle Haken ausgewählt und bei Schreiben alle Haken abgewählt.
Ich melde mich wenn ich neue Erfahrungen habe.

Hier ein Bild vor dem Speichern...

... nach dem fehlerhaften Speichern (Auswahl der Zeilen habe ich nachträglich geändert, daher eine zu viel!)....


#4

Nee, nee, so war das nicht gemeint ...! :wink:
Also: die beste Einstellung für MP3s ist:

MP3 V1&V2: lesen, schreiben, entfernen erlauben
APE: nur entfernen erlauben.

Du kannst dir mal n Filter basteln (F3 drücken) mit folgendem Inhalt:
%_tag% HAS APE
Das zeigt dann alle Dateien mit APE-Tags.
Erkennst du welche von den lückenhaften wieder?


#5

Ah ja, ich war im falschen Fenster.
Bei mpeg war wohl schon alles richtig:

400/13000 Dateien hatten 'nen APE-Tag, allerdings nicht die markierten Songs auf meinem Beispiel-Photos. Die Fehler betreffen auch meistens nur 1-3 Songs von 10-30 gespeicherten.

Ich habe jetzt die ape-Tags entfernt und werde mal schauen ob es jetzt weiter auftritt.



#6

Leider kommt der Fehler immer noch vor....

Viellicht de-/installiere ich das Programm mal...


#7

In der Logdatei steht "read: Sharing violation ..."
Prüfe ob andere Programme den Zugriff auf die Dateien blockieren.


#8

Dem möchte ich hinzufügen, dass wir im Forum den Fall hatten, dass besonders unter win7 der Aufruf aus dem Explorer heraus per Kontextmenü zu den Zugriffsblockierungen führte. U.a. möchte der Explorer gerne die thumbs.db aktualisieren oder der Indizierer guckt zur gleichen Zeit in die Datei.
Also wäre schon ein gründliche Suche nach womöglich neugierigen Programmen nötig.


#9

Interessant!
Ich markiere immer die Ordner im Datei Explorer und lade sie per Kontextmenü in MP3Tag.
Ich werde den Explorer mal zulassen....


#10

Der Explorer wird es sehr wahrscheinlich nicht sein, wohl eher ein Indexdienst oder Virenscanner.

DD.20111022.1335.CEST


#11

hallo habe das gleiche problem.

Ich nutze das Programm auch seit Jahren bisher problemlos.

(Übrigens DAS Beste was ich kenne !)

Auch mit Win7 und Avira Antivir.

o.g. Problem ist erst ab der vers. 2.49.

Ärgerlich ist das die Tags komplett weg sind und auch der Dateiname. Ich habe schon vermutet daß es ein RAM oder Festplattenzugriff- oder Überschneidung Problem ist. Bin mir aber nicht sicher. Es kommt jedenfalls nur beim speichern vor. :astonished:

Gruß
karategeorgie


#12

Hallo,

den Fehler kann ich nur bestätigen. Er ist bei mir unter Win7-64 mit MP3TAG v2.49a reproduzierbar, hat aber eine unangenehme weitere Eigenschaft (jedenfalls bei mir):

Die betroffenen Dateien werden auf der HDD gelöscht!!!

Es wäre klasse, wenn der Fehler schnell behoben würde, denn das Tool ist seit Jahren das beste was man kriegen kann, nur so kann man es derzeit nicht einsetzen, leider.

Viele Grüße Heftzwecke


#13

In diesem Thread wurden ja nun eine Menge Workarounds und mögliche Fehlerursachen genannt (z.B. Zugriffsrechte, die nach Migration von Win 32 bit auf Win 64 bit nicht mehr stimmen) - tritt der Fehler nach Beseitigung dieser Ursachen immer noch auf?


#14

Also bisher funktionierte das Programm einwandfrei. Seit 2.49 treten die Probleme auf mit den zerstückelten Tags, deshalb habe ich mal hier im Forum geschaut ob andere das Problem auch haben.

Bei mir werden jedenfalls nicht nur die Tags zunächst zerstückelt angezeigt, sondern auch gleich die Dateien gelöscht. Zunächst dachte ich EAC hat die CD nicht richtig ausgelesen, aber aufgrund des Threads habe ich dann MP3TAG als Verursacher gefunden.

Die Workarounds habe ich nicht verstanden und meinen Virenscanner möchte ich nicht jedesmal ausschalten wenn ich meine Musiksammlung verwalten will.

Da ich scheinbar nicht der einzige bin, wenn auch mit weitreichenderen Komplikationen, vermute ich einen Fehler im Programm. Den Fehler kann ich reproduzieren, CD Rippen, MP3TAG im Explorer aufrufen, OGG-Files taggen, dann speichern und schwupp sind 1-3 Files flöten gegangen.

Mein System ist nativ auf WIN7-64 aufgesetzt worden und als Virenscanner läuft der aktuelle Kaspersky.

Andere Dateien verschwinden derzeit auf den Rechner nicht einfach mal so...


#15

Hmm ...
Sind die Dateien beim Bearbeiten ... eher ungewollt ... umbenannt ... oder irgendwohin verschoben worden?
Lassen sich die verlorenen Dateien im ursprünglichen Ordner mit einem File-Recovery-Tool wieder herstellen?
Sind die Dateien aus dem System tatsächlich völlig verschwunden?

DD.20111105.1630.CET


#16

Die Dateien sind gänzlich im Nirwana verschwunden und tauchen auch nicht im Papierkorb von Windows auf. Ein File-Recovery Tool habe ich nicht genutzt, da rippe ich die gelöschten Tracks lieber noch einmal schnell, bzw. verzichte auf den Einsatz von MP3TAG bis auf weiters ganz.

Bei bestehenden Dateien tritt das Problem nicht auf, nur bei frisch hinzugefügten nach obigem Vorgehen. Vielleicht verträgt sich wirklich irgendein im Hintergrund laufender Windowsdienst oder so nicht mit MP3TAG. Allerdings ist das Problem bisher bei über 17.000 Tracks nicht aufgetreten.

Ich versuche gelegentlich einmal eine CD an einem anderen PC (Notebook) mit Win7-64 zu rippen, mal schauen ob es da auch Probleme gibt.

Eindeutig werden die Dateien jedenfalls gelöscht, wenn man mit MP3TAG interagiert, sprich eine Änderung abspeichert.


#17

:unsure:Hallo, melde mich nochmal.

Auch ich habe das Problem immer noch.

Allerdings werden bei mir nicht kommplet die Dateien gelöscht sondern nur die Tags die gespeichert werden sollen. Teilweise sind auch die Dateinamen verschwunde ausser den Endungen ( z. B. *.mp3).

Ich habe das auf insgesamt 3 Rechnern probiert mit Windows 7 32bit und 64bit.
Immer reproduzierbar allerdings nicht immer gleich also nich bei jeder Speicherung.

Was mir aufgefallen ist : wenn ich zwischen dem Speichernklick der Maus, dem daraufolgendem optischen Verschwinden der Tags keinen Klick mit der Maus oder Tastaturbetätigung ausführe, dann einfach mit der Tastatur die verschwundenen Titel bzw.Tags anfahre werden sie auf einmal sichtbar und man kann sie problemlos speichern.

Ich hatte den Verdacht :angry: in der Einstellung beim Menü der Ansicht im Explorereinstellung: Immer Symbole statt Miniaturansichten darstellen, habe es geändert aber es hat im Prinzip nicht geholfen.

De Fehler tauchte meiner Meinung erst mit der Vers. 2.49a auf.

Ausser aktuellen Virensignaturen habe ich keine Soft-und Hardwareänderungen gehabt.
Ich denke daß es ein Softwareproblem imTageditor in der o.g. Version ist.

Wäre froh wenn jemand eine Lösung hätte da ein normales Arbeiten fast unmöglich ist. Schade! :unsure:

Gruß Jiorgo


#18

Wo genau verschwindet ein Dateiname?
Wo siehst du als Dateiname "*.mp3"?

Ich habe diesen Effekt auch schon mal gesehen, aber lange Zeit nicht mehr.
Sind die Dateien verschoben worden?
Ansicht aktualisieren [F5] sollte in diesen Fällen helfen.

Vielleicht wird der eine Tag-Typ gelesen und entfernt, dabei aber ein anderer Tag-Typ geschrieben?
Kontrolliere die Einstellungen in "Optionen/Mpeg".

DD.20111230.1655.CET


#19

Hallo erstmal,

also,

der Dateiname verschwindet wenn ich vergesse, so wie du auch schreibst, auf Ansicht aktualiseren zu drücken, ergo werden - da ja kein Tag sichtbar ist - auch keiner als Dateiname (zB. Artist - Titel) übernommen.
Dies ist nachvollziehbar da, wenn kein Tag, natürlich auch kein Dateiname vorhanden - logisch nur .mp3.
Ist aber sehr störend da bei langen Listen, wenn dies ausserhalb des sichtbaren Feldes des Monitors stattfindet und man es erst säter merkt und nicht weiß später welches Stück dies überhaubt ist.

Also bei mir werden die Dateien nicht verschoben. wie gesagt "Ansicht aktualisieren" Tags sind meistens zu 99% da aber schon beim nächsten Titel speichern ist derjenige wieder weg, wieder Ansicht aktualiseren uns so weiter.

Wie meinst du das mit "Vielleicht wird der eine Tag-Typ gelesen und entfernt, dabei aber ein anderer Tag-Typ geschrieben?
Kontrolliere die Einstellungen in "Optionen/Mpeg" ??

Ich schreibe den Tag => zB. Artist - Titel => speichern =>TAG ist verschwunden =>Ansicht aktualisieren=> Tag ist Da !! => TAG - Dateiname=> Fertig

Was wäre die RICHTIGE Einstellung/en bei Optionen/Mpeg?
Habe dort bisher noch nie was verändert. Ausser Updates vom Editor sonst keine Änderung.

Im Voraus schon mal DANKE für dein Bemühen!

Gruß Jiorgo


#20

Hmm ... logisch klingt das alles nicht.
Ein Dateiname ist immer da, wenn eine Datei da ist und umgekehrt.

Was als Dateiname in Mp3tag angezeigt wird, das ist der Dateiname wie Mp3tag ihn liest via Betriebssystem vom Dateisystem.

Wenn in Mp3tag die Spalte mit dem Dateinamen nach der Bearbeitung einer Datei leer wird, so ist das außergewöhnlich eigenartig.

Besteht vielleicht eine Netzwerkverbindung zwischen Mp3tag und der mp3 Datei?
Könnte es sein, dass diese Verbindung nicht permanent besteht?
Könnte es sein, dass irgendein Disk-Pufferbereich nicht sofort automatisch aufgefrischt wird nach einer Mp3tag Transaktion?
Sind die Dateien sehr groß?

Wie gesagt ... Fragen über Fragen ... Hardware ... Software ... Anwender ... Raumtemperatur ... Mondphase?

Die richtige Einstellung ist diejenige, die für dich richtig funktioniert.

Wenn du dem Problem systematisch auf den Grund gehen willst, dann probiere die unterschiedlichen Tag-Typen jeweils für sich allein aus: ID3v1 oder ID3v2.3 oder ID3v2.4 oder APE.
Die Optionen Lesen, Schreiben, Entfernen jeweils einstellen für nur einen Tag-Typ.
Alle übrigen Tag-Typen jeweils deaktivieren.
Und dann nur mit einem Ordner mit Testdateien experimentieren.

DD.20120105.1918.CET