"entfernen" eines Tag-Feldes ohne Wirkung


#1

Hallo zusammen,

ich möchte bei mehreren mp3 eines Albums gleichzeitig Einträge entfernen. Leider passiert bei der Aktion nichts.

Ich markiere erst die Dateien, wähle dann im Tag-Panel z.B. unter Album-Interpret "< entfernen >" und klicke dann oben auf das Disketten-Symbol "speichern". Anstelle der Aktualisierung aller Dateien, springt der Album-Interpret wieder zurück auf den ursprünglichen Eintrag. Sonst passiert nichts.

In den Optionen ist unter Tags> Mpeg> Schreiben nur der Haken für ID3v1 gesetzt, bei > Entfernen der Haken für ID3v2 und APE, da ich für meine mp3 nur den ID3v1-Tag verwenden möchte.

Warum zeigt die Auswahl "< entfernen >" keine Wirkung?
Es ist übrigens egal, in welchem Drop-Down ich das ausführe und auch, ob es eine oder mehrere Dateien sind.

Gruß
Jojo der Gummimann


#2

Ganze Tagformate werden nicht einfach beim Speichern entfernt.
Wenn du bei deinen Schreib-Einstellungen etwas veränderst, bleiben ID3v2 und Ape Tags unverändert. Nur der Id3v1 ändert sich. Deshalb geht Albumartist nicht weg.

Willst du ID3v2 und Ape wirklich loswerden dann verwende die Funktion "Datei > Tag entfernen".
Dann sind die beiden Tagformate weg und Albumartist gleich mit.


#3

Ok, das ist nachvollziehbar und hat auch funktioniert. Danke!

Mich verwirrt dann aber die "entfernen"-Option im Tag-Panel in Zusammenhang mit den Einstellungen schreiben/entfernen. Das dortige Entfernen bezieht sich dann nur auf "Tag enfernen", während das "entfernen" im Tag-Panel sich auf "schreiben" bezieht.

Im Nachhinein ist es logisch, kann aber auch zuerst missverstanden werden, wie in meinem Fall. Vielleicht könnte man so eine Konstellation mit einem kleinen Hinweis abfangen, damit man darauf aufmerksam wird?


#4

In dem Fall schaftt die englische Sprachversion mehr Eindeutigkeit.
Tag-Panel: blank
Erweiterte Tags: Remove Field

und auch die niederländische unterscheidet da deutlicher.

Aber hilf Dir selbst:
Ein eigenmächtiges Ändern in der Sprachdatei im Programmunterordner "lang" beim Eintrag "_M_STR_COMBO_REMOVE" schafft Dir die gewünschte Klarheit. :wink: