Explorer context menu missing on 311 in windows 11 21H2 22000.282

Just updated to 311 and have lost the explorer context menu

image

Have you updated from an Administrator or from a Standard user account? Also, I assume you have the option to install the context menu extension checked during installation?

Can you run this command from Windows Powershell and see if there is any output?

get-appxpackage -name *mp3tag*

Yes from Administrator.
Yes for option selected. (even tried without then with just to try to refresh it)

get-appxpackage -name mp3tag

Name : 35795FlorianHeidenreich.Mp3tag.ShellExtension
Publisher : CN=Florian Heidenreich, O=Florian Heidenreich, S=Sachsen, C=DE
Architecture : X64
ResourceId :
Version : 3.11.0.0
PackageFullName : 35795FlorianHeidenreich.Mp3tag.ShellExtension_3.11.0.0_x64__hyhc94k68ebpm
InstallLocation : C:\Program Files\WindowsApps\35795FlorianHeidenreich.Mp3tag.ShellExtension_3.11.0.0_x64__hyhc94k68ebpm
IsFramework : False
PackageFamilyName : 35795FlorianHeidenreich.Mp3tag.ShellExtension_hyhc94k68ebpm
PublisherId : hyhc94k68ebpm
IsResourcePackage : False
IsBundle : False
IsDevelopmentMode : False
NonRemovable : False
IsPartiallyStaged : False
SignatureKind : Developer
Status : Ok

HTH

Thanks for the details. Looks good to me.

Not sure what you’re using for testing the context menu - based on other feedback and local tests, it's only available on folders and supported file types from the right part of Windows Explorer, not from the tree on the left.

Also, did a reboot change anything?

To test, just right mousing on mp4 file.
Just rebooted and menu now has icon and text.
Having never needed to reboot before, a reboot reminder at the end of install may be needed.
Thanks.

OK great — happy it’s working now!

A reboot was also never needed in my countless tests, but I’ve noticed that it sometimes can take some time for the menu item to appear. This is most likely due to the asynchronous nature of the provisioning process.

It’s all pretty new and I’m learning from the feedback :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.