Export nach "html_link_sort-T-I-D" fluppt nicht.


#1

Hallo!

Ich war bisher immer topp zufrieden mit Mp3tag. Heute allerdings ist mir folgender Fehler aufgefallen. Bzw. Es könnte auch meine Dummheit sein, aber ich find den Fehler bei mir nicht...

Es handelt sich um folgendes: Ich wollte gerne von meiner Sammlung an Mp3s (immerhin über 1800 Stück) eine komplette Übersicht erschaffen. Ich habe also alle in das Bearbeitungsfeld geladen, alle Tags einlesen lassen, alle ausgewählt und daraufhin die Exportfunktion gestartet.

Die Liste, die ich da rausbekam, war auch prima sortiert, allerdings waren die Spalten Spielzeit, Bitrate, MPEG Version und Mode bei fast allen MP3s leer, lediglich vielleicht ein Dutzend scheinbar zufällig ausgewählter Titel wurde mit vollständigen Informationen angezeigt...

Ich kann mir leider nicht helfen... Liegts vielleicht an der Anzahl der MP3s? Weil, ich glaube mich erinnern zu können, mit weniger MP3s hätte es funktioniert....

Hoffe, der Fehler klärt sich!

Martin

PS: Kann man in der Exportfunktion auch irgendwie das Winamp-eigene "Sort by path and filename" reinbekommen?


#2

Hallo EmmJay,

die Header-Informationen werden nur exportiert, wenn auch ein gültiger Header vorliegt. Am besten Du lässt die MP3s mal von einem Tool wie EncSpot (siehe 'Links' auf mp3tag.de) testen.

Viele Grüße,
~ Florian


#3

Hey, danke für die schnelle Antwort.

Bei deinem Problemlösungsvorschlag hab ich allerdings zwei neue Probleme :slight_smile:

  1. Scheint der Link, den du empfohlen hast, tot zu sein.
  2. Habe ich sämtliche Tags mit Mp3tag schreiben lassen (Ich bin ein kleiner perverser Perfektionist, der in jeder Datei zumindest Interpret und Titel des Lieds stehen haben muss).
    Daher finde ich es seltsam, dass nur die allerwenigsten Tags angezeigt werden...

#4

Hallo nochmal!

Ich hab noch ein bisschen herumexperimentiert.

Die Sache mit dem Sortieren nach Pfadangabe hab ich in der Hilfe-Datei gefunden, das läuft also.
(Mit einer Kleinigkeit: Ich hab zwei Alben mit folgenden Namen: The Metal Opera und The Metal Opera Pt. II. Winamp sortiert sie in der Reihenfolge, wie ich sie hier geschrieben hab, Mp3tag stellt den Ordner mit dem Pt. II an erste Stelle, das aber nur anbei... - Ich weiß, ich bin ein Meckerfuzzi).

Was aber die Sache mit Spielzeit, Bitrate etc angeht, hab ich herausgefunden, dass die scheinbar "zufällig" ausgewählten Titel, die über alle Informationen verfügten genau diejenigen sind, die ich explizit im Bearbeitungsfenster mal angeklickt habe (also nicht nur über "Alles markieren" - "Tags einlesen" ausgewählt hab).

Kann man da was machen? Ich mein, ich kann ja nicht 1800 Dateien einzeln anklicken...?!


#5

Hallo EmmJay,

kann es sein, dass Du unter 'Optionen, Allgemein' die Option 'ID3-Tags bei Verzeichniswechsel nicht einlesen' aktiviert hast?

Wenn ja, verfügen natürlich nur die angeklickten Dateien über alle Informationen. Das Deaktivieren dieser Option müsste das Problem dann lösen.

Wegen der Sortierung schau ich nach meinem Urlaub (ab morgen früh bis 6.1.) mal.

Viele Grüße und schöne Weihnachten,
~ Florian

P.S.: Bitte gib nochmal Bescheid ob es dann 'fluppt' :wink:


#6

Tadaa!

Genau das war's! Nach dem Reaktivieren der Option werden direkt beim Öffnen des Verzeichnisses alle Tags eingelesen. Das hatte ich damals deaktiviert, als ich versehentlich mal meinen Mp3-Ordner geöffnet hatte. Jetzt werden beim Export auch alle Laufzeiten und die Bitrate angezeigt.

Liegt das denn daran, dass hinter der "Tags auslesen"-Funktion (STRG-T) eine andere Routine steckt als hinter dem Auslesen beim Öffnen eines Verzeichnisses?

Wünsch dir erstmal einen schönen Urlaub, ein frohes Fest und nen guten Rutsch.

Und danke für die abendliche Hilfe :wink:


#7

Uff! Das freut mich :slight_smile:

So ein Mega-Bug hätte mir vor dem Urlaub gerade noch gefehlt ...
Ich hab die 'ID3-Tag auslesen'-Methode hier schon so geändert, dass sie jetzt auch die Header ausliest. Danke für den Hinweis!

In der nächsten Version ist der Fehler dann behoben.

Viele Grüße,
~ Florian