Exporting To Excel?


#1

Hello...
I have a number of DVD's containing around 400 MP3's each.
I use Microsoft Office 2007 and want to export the MP3 Tag list exactly to Microsoft Excel.

I chose Export >csv...
Transfer was quick, Excel document opened, but the transferred information was not in columns as per MP3 Tag, but in lines of text with punctuation etc.

Can someone help?

Many thanks


#2

Then force Excel to open a CSV file - perhaps it got a hickup and tried to open it as plain text.


#3

Thanks for taking time to reply.
Don't quite know what you mean by 'force'!! Transfer happens automatically.
I've tried the above 3 times.
However, the third time it didn't transfer at all :angry:
Instead a notification window:
'New Export file cannot be opened for writing'

Anyone have any more suggestions or help? I must be missing something simple!!

Many thanks


#4

Well, instead of just double-clicking on the file in explorer you could open Excel, then use File>Open, select as file type "csv" (instead of xls etc).

You have to look what you export - is the first line one that complies with the CSV standard, that is it shows text separated by semicolon? Or is there some header?
If that is the case, Excel may be tempted to treat the file as plain text instead of csv.
Also, there is a fairly good help in Excel that explains how to import text files.


#5

Thanks again to all for taking time to reply.

After some research, I worked out how to do what I wanted and create a list in Excel.
However, I now have another problem: this time at least smaller! :rolleyes:

First of all: I uninstalled, then re-installed MP3 Tag.
Then I created the 'csv' file, then Convert > Text..Tag and transferred.
All information transferred correctly EXCEPT:

The column headed 'Length' (= Track Time) displayed correctly MP3Tag eg 01:23
I included 'Length' in the 'Format String' box during Conversion.
'Length' is chosen from 'Extended Field' list

However, when transferred, it did not show the Track Time in each cell but rather a three-digit number which bore no relation to the relevant Track Time! :unsure:

Can someone tell me why and how to fix this?


#6

The fix would be not to import the length as this is a property of the file anyway and set during conversion by the converter (not the one in Mp3tag, though).
The length stays the same regardless of any value you try to import. So I would assume that you have now created a user-defined field with the name LENGTH.


#7

Hi ohrenkino...many thanks for your patience and suggestion.
However, I tried not including 'Length' via 'Extended Fields'...but it STILL appeared as before.
Again, no track times. :astonished:
I'm completely stumped now...


#8

Please check the definition for the column for length:
Value: %_length%
Field:
sort by: %_length_seconds%
Numeric: x (ticked)

The field is left empty.