Extended File Data export BPM field


I have a folder of circa 400 audio files. I would like to make a list of these and save as a csv file.

However, some of the extended file data is not being included when exported as a csv (or html).

There is only one category that I seem to be having an issue with, which also happens to be the most important one, and that's BPM, or beats Per Minute.

All of my audio files have this field populated within it's properties and I can see it within MP3tag just before I export to csv but once I export it, it does not show (within the csv file)

Any help with this would be much appreciated


You likely need to add the BPM tag to the export configuration file. The default configuration does not include BPM.

You would have to show us the export script that you use.


How do I manipulate this?

Please check the documentation:

Let us know if you don't find the default export script or if you have questions about how to insert BPM in the existing export script.

This is the CSV that is being pulled back

This is how MP3Tag looks pre export

This is how the files look in explorer

Please show us the export script itself.
The one you get if you click on File -> Export and which you select and press the Edit-Icon in the Export configuration window.

I think you should change the default program to edit MTE files to a plain text editor - a spreadsheet is definitely not the best application to edit it.

Also, a screenshot makes it much more difficult for us to supply you with a modified script that you can transfer to your installation. I would actually not spend the effort to re-type the script over here.

You can edit this export script and add all the fields that you like , in your case add %bpm%; in the line that starts with $loop.

I would also edit the script to such an extent that I would remove all the superfluous fields that apparently have no data. I assume that these are ALBUM, TRACK and YEAR.

And finally: you would have to modify the way that you open the csv output and open the CSV file as an import from within the spreadsheet program where you can set the file type. Otherwise, you would not get the input separated into cells.

1 Like

As suggested by @ohrenkino you should change the default program for opening mte files to something like Notepad or Wordpad.

The first line of your file shows the headers for the output. These are just text names, separated by a semicolon. You can add “BPM;” to the end, or insert it wherever you prefer within that line.

The second line is the loop that grabs the actual data from each file in your list. Again separated by the semicolon in this case. You would have to add the field name “%BPM%;” to the end of this line as well, or insert it between whichever fields you did the same for the titles in line1.

Make sure you save the changes before exiting. And consider using a new filename so you can have both options.

1 Like

By the way, if you are using Excel to view the resulting csv file it should be opened from within Excel. That will open an import wizard so you can confirm the data types for each column, and even the separator character you choose. The default semicolon can be changed in the mte file to something less common, especially if you have any semicolons in some of your metadata already. Mine is set to the § character since I do not use this anywhere else.

A good alternative that is usually interpreted correctly, is the tab character: $char(9)