[F] Actions

bug-fixed

#1

I get a ugly error in some mp3s (5 of 40) when I do this

  • Create or select a action. This action contains just a Case conversion with Mixed Case on All fields.
  • Try to run the action on this file.

Here's the error log that it's generated


================================================================================
Mp3tag V.2.18a - 29.02.2004 - 14:57:47

OS-Version: Unbekannte Windows-Version

Build: Feb 29 2004 17:25:52

AppPath: 2.086.617.088 Bytes frei (D:\UTL\media\mp3tag)
DataPath: 3.619.794.944 Bytes frei (Z:\Documents and Settings\QuaKeD\Application Data\Mp3tag\data)
TempPath: 3.619.794.944 Bytes frei (Z:\DOCUME~1\QuaKeD\LOCALS~1\Temp\Mp3tag V.2.18a)
FileVersion mfc42.dll: 6.5.3014.0


THROW

File: d:\dev\projects_main\sstring.cpp
Line: 709

THROW

File: d:\dev\projects\mp3tag\mtaction.cpp
Line: 498

THROW

File: d:\dev\projects\mp3tag\mtaction.cpp
Line: 284

CATCH

File: d:\dev\projects\mp3tag\mtmainframethreads.cpp
Line: 582


I can upload the file with problems if that helps. I've tried with 2.17, 2.18 and 2.18a, and I get the same error everytime.


#2

I have the exact same problem... I've created an action with only a "Mixed case" conversion, and I get an error.

My girlfriend (Andrea, from the last post) gave me the CTRL-SHIFT-F5 combination, so I'm posting the log file on my site. Hope you find it useful.

Besides that, your program is excellent, I always look for a tagger with the flexibility of yours... thanks for your work!

Error Log ->MP3tag error log

From Argentina...
Fabian.


#3

Andrea and Fabian,
thank you for reporting and your nice feedback! I've hopefully fixed this bug with the latest Development Build :slight_smile:

Best regards,
~ Florian


#4

Thank you so much Florian! It works like a charm now :smiley:

Thanks for the excellent program! :w00t: