[F] Can't install into subfolder in start menu

On a relatively fresh installation of Win10, I tried to install mp3tag to the start menu folder Audio/mp3tag. Instead, it gets installed to the default mp3tag.

I see in the global ProgramData/Microsoft/Windows/Start Menu/Programs, there is no Audio folder. However, there is an Audio folder in /users/steve/appdata/roaming/microsoft/windows/start menu/programs.

I installed some other app earlier and had it put its stuff under /audio. It looks like the other app created Audio in my private area instead of making it global.

I'm not sure what happens in mp3tag when it is doing a "for everyone" installation and it can't find the folder ("Audio/mp3tag") for installation. Maybe it finds the personal one and then doesn't apply it correctly for a global installation.

If you installed a program into the Start menu folder, then you would see all the sub-ordinate files an folders.
Entries in the start menu are usually links to the program file in the installation folder.

But as electronic data processing does "think" I doubt that MP3tag looks around in your folder structure and then installs itself in a folder that only seems similar.

Do you see MP3tag in the apps list of the control panel?
Which installation folder do you see there?

What do you refer to if you write "stuff"?
The start menue (the global one and the user one) are only meant to get links to the exe-files in the program-folders. You never should place program files there.

BTW, MP3Tag does not ask for the possibility to install for all users. So it naturally only creates links in the startnmenu or the desktop for the user that installes it. If you want these links at a special place you have to do it yourself.

Windows 10 only shows entries in the start menue if they are links. The start menue does not show other files (exe, dll, txt ...). Also a folder is not shown if there are no links in it.

Hey all, thanks for the suggestions. But I'm pretty much familiar with the situation. Sorry if I wasn't specific enough in my initial DR.

It isn't an issue of whether EXE or links are being placed in the start areas. It is an issue of mp3tag ignoring the request to place the start menu items into a particular subfolder.

Sorry if I missed on the "install all/single user" -- I've been rebuilding the system and installing a lot of things! (Oh, it isn't "natural" to place it only in the single user. Many apps offer the option of all users/single user. There is no "natural", just different ways of doing things.)

Yes, mp3tag is in the control panel/manage programs area. I can uninstall it, and have done so.

By "stuff" i mean links to executables, docs, etc.

To reproduce:

  1. Ensure you have an ./Audio folder in your local user area. For me, that is /users/steve/appdata/roaming/microsoft/windows/start menu/programs .
  2. Start the mp3tag installer.
  3. When it presents the dialog box asking which folder to place it in, click on Audio. It'll change the destination from mp3tag to Audio/mp3tag.
  4. Let the installation complete.
  5. Open the start menu. mp3tag won't be under Audio. It'll be under its own mp3tag folder. This is the failed test point.

If you can't reproduce it, I'll spin up a VM when I have a chance and get some screen shots.

I don't want to mess up my system.
So, what happens if you create a link for MP3tag in that installation folder (even though the exe is already there): do you see the link in the start menu where you want it to be?

I think there is a basic misunderstanding: the selection of the installation folder has nothing to do with the final representation of MP3tag in the start menu.
And if poster poster is right, then Windows will not accept any other files than links in the start menu folder (i.e. display them).
AFAIK you cannot tell the MP3tag installation in which group the link should be added.

I can reproduce the bug.
Mp3Tag does not care about anything you tell the installation routine where it should put it's links for the start-menue.

Thanks all for reporting and confirming the issue. I've fixed it with the latest Development Build Mp3tag v2.83i.

Kind regards
– Florian

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.