[F] Comment Sorting

bug-fixed

#1

I have been entering Billboard info into the comment tag of a library of Top 100 songs from 1955 to date. I have a seperate directory for each year.

I prepare the directory by selecting all and < blank > the comments.

I then enter info in the format xx-yy-zz where xx is peak position, yy is peak weeks, and zz is Top 40 ranking for the year. There are usually many more files in a directory than the top 40. Those other comments are left blank.

I have added a "$right(%comment%,2)" sort function to the comment column.

Sort results are almost correct but some items are out of sequence. I see blank comment items merged into the commented list and sometimes I see commented items mixed in with blank items.

View refresh, plus column resort down and up will eventually (normally) fix the order.

Not a huge problem for me as I eventually transfer the ranking info over to Track which does sort properly.


#2

I'm not sure if I understand you, but did you expect that the list is instantly sorted after you've added the sort option to the comment field?

I don't see the bug here.


#3

I usually have order set to Title ascending while I am editing data and then switch to Comment ascending to check the data.

The problem shows up when I check to sorted (by function) data. As I said, it is almost correct. Just some (arbritary) items are out of order.


#4

Sorry, but I can't see any problem here. Maybe you can give me a concrete example which I can try to reproduce (including data)?


#5

Here is better sample data.

bytrack.csv shows the comment data, ordered by track. Produced by file -> export.

bycomment.m3u shows a typical result of sorting column by title and then by comment. Produced by file -> playlist.

The result is only typical because resorting produces a different order.

Moderation: attachments removed

#6

Thanks for pointing. I'll fix that to the next release!

$if(%comment%,$right(%comment%,2),) should work for now.

Best regards,
~ Florian


#7

:smiley:
That fixed the symptom. Thanks.


#8

The bug is fixed too now :slight_smile: