[F] Disappearing "cdec" tag in Nero AAC

bug-fixed
#1

Nero's AAC encoder writes a "cdec" tag with the settings used, e.g. "ndaudio 1.5.4.0 / -q 0.53 -lc". However editing any other tag in MP3Tag (I noticed it after adding album art) deletes the cdec tag, when it shouldn't.

BTW I'm using v2.45a

[F] Unknown MP4 atoms are deleted on save
#2

This should be preserved with the current Development Build.

#3

Great, thanks.

Edit: Actually I tried 2.45d, and it still deletes the cdec tag. :frowning:

#4

2.46a also deletes the tag. Additionally, it doesn't display it in View > Tag. Are previous versions still available for download somewhere? This tag is important to me, and I don't want to risk and loose it.

#5

And I wondered for a while why that information sometimes got lost. Thats a very annoying bug and that makes mp3tag currently nearly unusable for me. Why does it took so much time to change that? :confused:

Is there a way to rewrite those cdec informations?

#6

Menedas,

you are currently using version 451 (see your personal Information), it would be nice to hear what happens with the current Build version 2.49.

As the OP is about the AAC Encoder, this is from the changelog from 2.49
[2011-05-15] NEW: added support for preserving unknown MP4 atoms when writing tags.

#7

No, I have tried it with the current 2.49.

EDIT: My personal informations said "Mp3tag Version: No Information". No idea where you get your information that I'm using 451.

And is there an answer on that:
Is there a way to rewrite those cdec informations?

#8

Sorry my mistake. Misread the info

#9

So, whats next?

#10

It should be possible by writing a field with the name cdec. To make the field be written in lower case you'll need to use an action:
Action type: Guess values
Source format: The encoding info
Guessing pattern: %cdec%

#11

That works. Great :slight_smile:

#12

Is there a schedule when this bug will be solved? Because its still a bit annoying to always rewrite the tags manually after using mp3tag.

#13

I have tested the new Version 2.49b which should solve the problem, but the problem is still exists. Strange. That was the second or third try to get rid of it. Seems more complicated.

Maybe neroaacenc is saving his tags data in a different way.

#14

I have no information that 2.49b is supposed to solve the problem, sorry.

#15

It said "FIX: cpil atoms (compilation at MP4) set to 00 were not displayed."

I thought that could be my mentioned problem.

#16

No, that was a different issue.

Can you tell me how you use the nero encoder? (from cmd line or with some program)

#17

I'm using foobar2000 and neroaacenc 1.5.1 with those parameters:

-q 0.50 -ignorelength -if - -of %d

#18

The problem that tag "cdec" gets lost is still the case.
The tag gets losts when I do tag changes via mp3tag.
I am on v2.65a

This is a real pitty as mp3tag is one of my master tools and on the other side I do not want to loose the encoding info within cdec.

  1. Question
    Is it agreed that this is an mp3tag bug? and will there ever be a fix?

  2. Question
    Is there any known workaround?
    As dano proposed on Aug 2nd, 2011 a workaround? If yes, pls can anybody explain to me.

  3. Question
    If there is no fix nor workaround available, I am wondering to move from neroaac to qaac.
    Is my understanding correct that mp3tag is anyhow more focused on Apple's implementations as I found on mp3tag homepage ("...support for iTunes-specific tags ...")?
    Perhaps Nero's aac implementation will anyhow sooner or later dispear. There was no update / development for many years.

Finally, I want to draw your attentation to these tools:
https://mediaarea.net/de/MediaInfo
https://github.com/lordmulder/mediainfo-gui...eases/tag/v2.13
Excellent tools to analyze which tags are really availble in a file.

#19

The "cdec" field should now be preserved using the latest version Mp3tag v2.66.

Kind regards
Florian

closed #20

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.