[F] Discogs stopped working on 2.74


Hi, my ssd died the other day and today installed a new copy of mp3tag but discogs is giving a oauth error saying it's invalid or timed out, downloaded a 2.73 from some random site to try on a virtual machine and it worked without any issues so guessing it's something with 2.74?

Could you post an official link for 2.73 please so i can install on my main machine until the issue is sorted?


On the 1 or maybe 2 times that 2.74 discogs script didn't give invalid token while i was testing when entering the code on mp3tag would give a bad gateway error and not get added on discogs applications.


Thanks for your report. Two additional questions:

  • Which version of Windows are you using?
  • Have you tried to uninstall Mp3tag (backup first, but including removing the configuration)?
The official link to v2.73 is http://download.mp3tag.de/versions/mp3tagv273setup.exe

Kind regards


Thanks Florian, Windows 10 pro 64 bits.

Yeap i did try uninstalling 2 times and deleting %appdata%/mp3tag

Cheers for the link, i'll give it another try with 2.74 and report back for more info.



Another attempt: Can you check your system time and make sure that it's correctly set?

Kind regards


Yeap, date is correct, just tried again with 2.7.4 with a fresh windows install and got the same issue.

Here's a screenshot with the exact error.


and the sort of tokens it's generating in case it may help at all to see what could be wrong.



Your second screenshot gave a good hint for the possible issue. Can you please try this version?






I have the same problem since updating to 2.74.

I have downloaded the version in the previous post and can confirm Discogs authorisation is now working.


Testing now, and also figured so that's why i went back and added the second screenshot since figured it would be easier in case of for example the characters at the end not being intended heh.

Going to test it and will get back to you when done.

Thanks for the quick help.


I just had the exact same problem as the first poster; running the updated binary fixed this issue.
Thanks - and you just earned a donation!


Yeap, working great in the new version Florian :slight_smile:, guess it was the weird chars at the end of the token? like last 3 or so.

Thank you very much for the quick fix :slight_smile:


Thank you all for reporting the issue and testing the fix. I've just release Mp3tag v2.74a, which fixes the issue officially.

And yes, cpoink, the issue was with those weird characters at the end of the token. This buffer was not correctly terminated :slight_smile:

Thanks again!