[F] Does not delete multiple extended tags with trailing blanks

bug-fixed

#1

I had some files with erroneous extended tags - two extra fields named "ARTIST " and "ARTIST - ", containing the filename. When using the extended tags dialog for all the files with those tags, it is impossible to delete those tags. When I try to blank the field with the extra space, the proper artist field is selected for blanking. When trying it with the "ARTIST - " one, an extra, fourth artist-field suddenly jumps up in the box. When selecting the files one by one everything works as expected. It's reproducible, just tag two files as described.

And now - how do I get rid of those two bad artist values I just filled in to test this, that now appear on the drop-down list when I want to add extended fields...? :stuck_out_tongue: It's in the registry somewhere? :book:


#2

I've tried to reproduce this but had no success. To remove the erroneous field names, just press [Shift+Del].

Kind regards,
Florian


#3

Thats strange. Did you add and work on those tags on multiple files, not just one at a time? I added some images of how it looks for me. On the first one I have added those extra tags on two files, and the two following shows what it looks like after I have pressed delete on the erroneous fields. And now I notice what's happening - mp3tag is stripping off the blank in the end when marking for deletion, so the first one becomes the real artist field.




#4

I've only tried it with one file (which works) and now reproduced the bug with multiple files.

I'll fix it to the next release. Thanks for reporting!

Kind regards,
Florian


#5

Sorry, I guess I wasn't very clear with the problem only being when working on multiple files. And thanks yourself! I'm happy spending fifteen minutes on something small like this compared to you having spent hundreds and hundreds of hours working on the whole application...


#6

This should be fixed with the latest Development Build.

Thanks for reporting!

Kind regards,
Florian