[F] Export BOM falure

bug-fixed

#1

With no $filename() in the config, Tools | Options... | Export, [X] Write BOM fails to work.

Note: C:\Program Files\Mp3tag\help\options_export.html says

Write BOM
Mp3tag exports data in Unicode format encoded as UTF-8 by default. This option enables writing of a Byte Order Marker which is required by some applications.


#2

This is mainly a documentation issue.

Initially I used UTF-8 as default but changed that due to many "Bug Reports" caused by third-party applications not supporting UTF-8 files. Obviously, I forgot to update the corresponding topic in the help.

Fixed.


#3

Confirmed documentation fixed in V2.39n:

Write BOM
If you enabled writing of UTF-8 or UTF-16 via the $filename function in the export configuration, this option enables writing of a Byte Order Marker which is required by some applications.