[F] Export wird nach Update auf Version 2.86b nicht mehr abgearbeitet


#1

Moinsens,

Ich benutze Scripte um gefilterte Playlisten zu erstellen. Seit der Version v2.86b wird noch das Infofenster angezeigt aber die Playlisten werden nicht mehr geschrieben. MP3Tag hängt sich mit 12% Prozessorlast weg.

Hier mal eines der Scripte welche ausgeführt werden sollen:

$filename('D:\liquidsoap\playlists\buffer\ktra.m3u',ansi)
'#EXTM3U'
$loop(%_filename%)$loop(%title%)$puts(FilterStatus,1)

$puts(FilterStatus,$ifgreater($len(%replaygain_track_gain%),0,$get(FilterStatus),0))
$puts(FilterStatus,$ifgreater($strstr(%_folderpath%,'Amazon'),0,0,$get(FilterStatus)))
$puts(FilterStatus,$ifgreater($strstr(%_folderpath%,'(Kutski)-Keeping the Rave Alive'),0,$get(FilterStatus),0))

$puts(FilterStatus,$ifgreater(%_length_seconds%,1800,$get(FilterStatus),0))

$ifgreater($get(FilterStatus),0,'#EXTINF:'%_length_seconds%','%ARTIST%' - '%TITLE%
%_path%,)
$loopend()$loopend()

Von diesem Script gibt es noch andere welche alle nacheinander abgearbeitet werden sollen. Nach einem Downgrade auf v2.86a arbeitet MP3 Tag wieder richtig. Es werden ca. 25000 Files gescannt umd die Playlisten zu erstellen.Die Aktionsliste sieht dann wie folgt aus.

Bild1

Hinweis: Es wird kein Errorlog erzeugt.

Hoffe das war verständlich, wenn es Fragen gibt oder die Scripte benötigt werden einfach melden.

Greetz
LostSoul


#2

so ganz kann ich das nicht nachstellen.
habe eben eine Kopie deines Skripts auf meine Dateien losgelassen und MP3tag bleibt nicht hängen. Es werden auch Ausgaben erzeugt. Nur da die Bedingungen nicht zutreffen, gibt es keinen weiteren Text.
Nur die Aussage, dass prinzipiell keine Skripts mehr abgearbeitet werden, ist so nicht richtig.
Kannst du mal - aus einfacheren Debug-Gründen - eines der Skripte, die bei der Installation mitgeliefert werden, z.b. das CSV-Skript ausprobieren? Ob es das tut?


#3

Ich habe den Anfangspost nochmal angepasst. Du hast natürlich Recht. Mit der Überschrift habe ich mich vertan. Das Debug werde ich heute Abend dann testen. Aber es ist schon verwirrend. Hast Du mir nicht sogar dabei geholfen die MTEs zu erstellen? Ich bin mir sicher das ich mich damals auch an die Community gewendet habe...


#4

Ich habe das Skript einmal über den Aufruf Datei>Export und einmal über Aktion(Quick)>Export getestet. Es bleibt nicht stehen.


#5

Hallo @Lostsoul

danke für die Fehlermeldung! Könntest Du es mit dieser Version nochmal ausprobieren?

https://download.mp3tag.de/support/F7DD1A7B-4E78-41B7-8FA2-8D5AF170EDBC-28621/mp3tagv286bsetup.exe

Danke! — Florian


#6

Hi Florian,

Hab Sie ausprobiert und sie arbeitet den Export ordnungsgemäß durch.

Danke dafür... :+1:t2:

Da Ohrenkino die KTRA.mte schon getestet hatte und dort nichts vorfand hänge ich mal den kompletten MTE Files Block als Archiv an diesen Thread. Da sind dann alle Files drin welche auch auf dem Bild zu sehen waren.

Da Du es wieder zum laufen gebracht hast gehe ich davon aus das die Syntax in den MTE Files korrekt war aber wenn Du es Dir vielleicht mal ansehen willst...

Greetz
LostSoul

All used Exports MTE.zip (5.1 KB)


#7

Hi LostSoul,

super — vielen Dank für's Ausprobieren. Der aktuelle Development Build Mp3tag v2.86c sollte das Problem jetzt offiziell beheben.

Danke! — Florian


#8

Hi Florian,

Läuft wieder Top. Super Service. Danke für die Hilfe auch an Ohrenkino...

Greetz
LostSoul

PS: Die Progressbar (von welcher ich in einem englischen Post gelesen habe) zeigt immer noch seltsame Werte an. Gezählt wird korrekt aber die Bar selber stellt die Aktionen nicht richtig dar. Allerdings hat und hatte das nie negative Auswirkungen auf die Abarbeitung der MTE Files.


#9

Hi LostSoul,

Meinst Du damit, dass die Progressbar für jeden Export von neuem loszählt oder dass sie auch mit der v2.86c bei Dir nichts anzeigt und wie eingefroren erscheint?

Danke! – Florian


#10

Hi Florian,

Also das Zählen an sich wird richtig angezeigt. Lediglich die Bar zeigt unsinnige Darstellungen. Wie gesagt wir reden von ca. 25000 Files. Das Fenster zählt richtig aber die Bar schafft beim ersten einlesen nicht die 100%. Wenn er dann weitermacht geht die Bar auf 100 und bleibt dann bis zum Ende auf 100%. Das wiederholt sich so für jedes MTE in der Liste.

Bild1 Alle Tags sind eingelesen. (Bar < 100%)

Bild3 Das von dem Script erzeugte File wird geschrieben.

Bild4 Die Bar erreicht nun zu früh die 100%.

Und dann geht das mit dem nächsten MTE genauso weiter. Die Texte und Zahlen werden richtig dargestellt die Bar bleibt aber weiterhin auf 100% stehen.

Da fällt mir ein, während des Exports ist die Anzeige noch durch einen Filter belegt.

NOT %_folderpath% HAS "amazon"

Insgesamt braucht MP3Tag gut 30 Minuten bis er alle meine MTE Files aus der Liste abgearbeitet hat. Das ist jetzt keine Kritik an der Geschwindigkeit zeigt aber das diese Fehldarstellung lediglich ein kosmetischer Fehler ist.

Greetz
LostSoul


#11

Hi LostSoul,

dann bin ich beruhigt :slight_smile: Diese Unregelmäßigkeiten liegen daran, dass der Export je nach Anzahl der Schleifen unterschiedlich viele Einträge produziert.

Ich hatte es damals nicht hinbekommen das vorauszusehen ohne den Export auszuführen — ich schau es mir bei Gelegenheit mal wieder an.

Danke! – Florian


#12

Hi Florian,

Es sollte tatsächlich keine Kritik an der Schleifengeschwindigkeit sein. Im Gegenteil, Respekt das Du bei der Abarbeitung der Schleifen eine Möglichkeit gefunden hast, nicht den Speicher zu zerlegen, sei die Loop auch noch so abenteuerlich. :+1:t2: (Also so lange man sich an die Syntax hält :wink: )

Greetz & THX
LostSoul