[F] "Favourite directory" requires a trailing backslash


#1

After a fresh install of 2.73 (tried 2.73a also) on a newly built Windows 10 PC, I set "Tools > Options > Directories > Favourite directory" to "E:\Music".

Both the "Subdirectories" and "start from this directory" checkboxes are ticked, but when I start mp3tag - the Directory it tries to read music from instead defaults to the install directory "C:\Program Files (x86)\Mp3tag".

If I change the "Favourite directory" setting to "E:\Music" and restart the program, it opens and starts reading tags as expected, with Directory displayed as "E:\Music".

There is likely a better way to set mp3tag's starting directory (leaving "Favourite directory" blank and using "File > Change directory" probably), however using the method I used, I think that both "E:\Music" and "E:\Music" in the "Favourite directory" field should produce the same results.


#2

The optional favorite setting "E:\Music" is the same as Mp3tag displays in its window header line, which looks ok for me.
Do you see the missing trailing backslash in the Tag-Panel window?
I think we have discussed this topic already, ... and I support this wish, that the current directory path string should have the trailing backslash also in the Tag-Panel window.

DD.20160116.1107.CET


#3

I've attached one screenshot showing the program after startup with Favourite directory set to "E:\Music" (blank results - reading from Program Files instead) and another screenshot showing the program after startup with Favourite directory set to "E:\Music" (correct results).

The problem isn't so much what displays in the window header line or in the Tag-Panel window; it's more the fact that the wrong directory is being read when the trailing backslash is not included in the Favourite directory setting.




#4

I think I've already fixed this with the current Development Build v2.73c (and forgot to document the change in the changelog).

Can you please try again with the latest version?

Kind regards
Florian


#5

Even if I forcefully remove the trailing backslash in the path of the default directory, MP3tag adds it and therefore opens the correct folder.
Yet: the tag panel shows the same path without backslash in the field for path ...


#6

I've changed this with v2.73d.

Kind regards
Florian


#7

Just updated to v2.74a. Confirmed all fixed!
It's much appreciated, I just sent you some Euros for your trouble. :wink: